'Fix' gpe-package and incorrect usage of head in twin's configure.
authorchris@(none) <chris@(none)>
Tue, 27 Jul 2004 13:55:03 +0000 (13:55 +0000)
committerchris@(none) <chris@(none)>
Tue, 27 Jul 2004 13:55:03 +0000 (13:55 +0000)
BKrev: 41065eb7y6GkI6_xDDClo_98PnH1sw

gpe-package/gpe-package-0.0.9-1/fix_interface_c.patch [new file with mode: 0644]
gpe-package/gpe-package-0.0.9-1/remove_translations.patch [new file with mode: 0644]
gpe-package/gpe-package_0.0.9-1.oe
ipkg/ipkg-0.99.126/uninclude-replace.patch [new file with mode: 0644]
ipkg/ipkg_0.99.126.oe
meta/meta-gpe.oe
twin/twin-0.4.6/cross_compile.patch

diff --git a/gpe-package/gpe-package-0.0.9-1/fix_interface_c.patch b/gpe-package/gpe-package-0.0.9-1/fix_interface_c.patch
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/gpe-package/gpe-package-0.0.9-1/remove_translations.patch b/gpe-package/gpe-package-0.0.9-1/remove_translations.patch
new file mode 100644 (file)
index 0000000..e69de29
index e69de29..9953bb9 100644 (file)
@@ -0,0 +1,17 @@
+inherit gpe
+
+DESCRIPTION = "A package manager GUI for GPE"
+DEPENDS = "libipkg libgpewidget libdisplaymigration libgpepimc"
+RDEPENDS = "gpe-icons"
+SECTION = "gpe"
+PRIORITY = "optional"
+BROKEN = "1"
+
+SRC_URI = "http://gpe.handhelds.org/pub/projects/gpe/source/${PN}-${PV}.tar.gz \
+           file://fix_makefiles.patch;patch=1 \
+          file://remove_translations.patch;patch=1 \
+          file://fix_interface_c.patch;patch=1"
+
+do_compile() {
+       oe_runmake STAGING_INCDIR="${STAGING_INCDIR}"
+}
diff --git a/ipkg/ipkg-0.99.126/uninclude-replace.patch b/ipkg/ipkg-0.99.126/uninclude-replace.patch
new file mode 100644 (file)
index 0000000..e69de29
index 3b79d81..dccb257 100644 (file)
@@ -10,7 +10,8 @@ FILES_libipkg = "${libdir}"
 AUTO_LIBNAME_PKGS = "libipkg"
 
 SRC_URI = "cvs://anoncvs:anoncvs@cvs.handhelds.org/cvs;module=familiar/dist/ipkg;tag=${@'V' + oe.data.getVar('PV',d,1).replace('.', '-')} \
-       file://varargs.patch;patch=1"
+       file://varargs.patch;patch=1 \
+       file://uninclude-replace.patch;patch=1"
 S = "${WORKDIR}/ipkg/C"
 
 inherit autotools 
index 40ad57c..b8f1dcd 100644 (file)
@@ -44,6 +44,7 @@ gpe-task-utils = "\
     minilite \
     miniclipboard \
     gpe-taskmanager \
+    gpe-package \
     gpe-clock \
     gpe-appmgr \
     gpe-terminal \
index 44b675b..7f8163a 100644 (file)
@@ -1,27 +1,6 @@
-diff -urNd ../twin-0.4.6-r0/twin-0.4.6/configure.in twin-0.4.6/configure.in
---- ../twin-0.4.6-r0/twin-0.4.6/configure.in   2003-03-27 08:29:47.000000000 +0000
-+++ twin-0.4.6/configure.in    2004-07-24 13:37:10.000000000 +0100
-@@ -378,7 +378,16 @@
-              select strdup strerror strspn strstr scandir alphasort uname \
-              vprintf vsprintf vsnprintf wait3 wait4 getpt grantpt unlockpt ptsname)
--AC_CHECK_FILE(/dev/ptmx)
-+AC_SEARCH_LIBS(openpty,util,
-+   [
-+       AC_DEFINE(HAVE_OPENPTY,1,[define if you have openpty function])
-+       no_dev_ptmx=yes
-+   ])
-+AC_CHECK_FUNCS([_getpty])
-+if test -z "$no_dev_ptmx" ; then
-+    AC_CHECK_FILE(/dev/ptmx)
-+fi
-+
- AC_CHECK_FUNC(crypt,,AC_CHECK_LIB(crypt,crypt))
- AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen))
- AC_CHECK_LIB(ltdl,lt_dlopen)
 diff -urNd ../twin-0.4.6-r0/twin-0.4.6/Makefile.in twin-0.4.6/Makefile.in
---- ../twin-0.4.6-r0/twin-0.4.6/Makefile.in    2003-03-27 08:29:47.000000000 +0000
-+++ twin-0.4.6/Makefile.in     2004-07-24 13:23:48.000000000 +0100
+--- ../twin-0.4.6-r0/twin-0.4.6/Makefile.in    2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/Makefile.in     2004-07-27 13:04:46 +01:00
 @@ -71,33 +71,33 @@
  # to correctly generate include/autoconf.h
  #
@@ -76,9 +55,69 @@ diff -urNd ../twin-0.4.6-r0/twin-0.4.6/Makefile.in twin-0.4.6/Makefile.in
  
  #
  # was:
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/configure twin-0.4.6/configure
+--- ../twin-0.4.6-r0/twin-0.4.6/configure      2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/configure       2004-07-27 13:11:21 +01:00
+@@ -1235,7 +1235,7 @@
+ make_is_good=no
+ if test "${MAKE-make}"; then
+-  ${MAKE-make} -v | head -1 | cut -d' ' -f1-4 | cut -d, -f1 | \
++  ${MAKE-make} -v | head -n 1 | cut -d' ' -f1-4 | cut -d, -f1 | \
+   while read make_GNU make_Make make_version make_numbers
+   do
+     if test "$make_GNU" = "GNU" -a "$make_Make" = "Make"; then
+@@ -2167,7 +2167,7 @@
+   lt_cv_file_magic_cmd='/usr/bin/file -L'
+   case "$host_os" in
+   rhapsody* | darwin1.[012])
+-    lt_cv_file_magic_test_file=`echo /System/Library/Frameworks/System.framework/Versions/*/System | head -1`
++    lt_cv_file_magic_test_file=`echo /System/Library/Frameworks/System.framework/Versions/*/System | head -n 1`
+     ;;
+   *) # Darwin 1.3 on
+     lt_cv_file_magic_test_file='/usr/lib/libSystem.dylib'
+@@ -3670,7 +3670,7 @@
+     # If the export-symbols file already is a .def file (1st line
+     # is EXPORTS), use it as is.
+     # If DATA tags from a recent dlltool are present, honour them!
+-    archive_expsym_cmds='if test "x`head -1 $export_symbols`" = xEXPORTS; then
++    archive_expsym_cmds='if test "x`head -n 1 $export_symbols`" = xEXPORTS; then
+       cp $export_symbols $output_objdir/$soname-def;
+       else
+       echo EXPORTS > $output_objdir/$soname-def;
+diff -urNd ../twin-0.4.6-r0/twin-0.4.6/configure.in twin-0.4.6/configure.in
+--- ../twin-0.4.6-r0/twin-0.4.6/configure.in   2003-03-27 08:29:47 +00:00
++++ twin-0.4.6/configure.in    2004-07-27 13:18:07 +01:00
+@@ -188,7 +188,7 @@
+ make_is_good=no
+ if test "${MAKE-make}"; then
+-  ${MAKE-make} -v | head -1 | cut -d' ' -f1-4 | cut -d, -f1 | \
++  ${MAKE-make} -v | head -n 1 | cut -d' ' -f1-4 | cut -d, -f1 | \
+   while read make_GNU make_Make make_version make_numbers
+   do
+     if test "$make_GNU" = "GNU" -a "$make_Make" = "Make"; then
+@@ -378,7 +378,16 @@
+              select strdup strerror strspn strstr scandir alphasort uname \
+              vprintf vsprintf vsnprintf wait3 wait4 getpt grantpt unlockpt ptsname)
+-AC_CHECK_FILE(/dev/ptmx)
++AC_SEARCH_LIBS(openpty,util,
++   [
++       AC_DEFINE(HAVE_OPENPTY,1,[define if you have openpty function])
++       no_dev_ptmx=yes
++   ])
++AC_CHECK_FUNCS([_getpty])
++if test -z "$no_dev_ptmx" ; then
++    AC_CHECK_FILE(/dev/ptmx)
++fi
++
+ AC_CHECK_FUNC(crypt,,AC_CHECK_LIB(crypt,crypt))
+ AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen))
+ AC_CHECK_LIB(ltdl,lt_dlopen)
 diff -urNd ../twin-0.4.6-r0/twin-0.4.6/makerules twin-0.4.6/makerules
---- ../twin-0.4.6-r0/twin-0.4.6/makerules      2003-03-27 08:29:48.000000000 +0000
-+++ twin-0.4.6/makerules       2004-07-24 13:24:13.000000000 +0100
+--- ../twin-0.4.6-r0/twin-0.4.6/makerules      2003-03-27 08:29:48 +00:00
++++ twin-0.4.6/makerules       2004-07-27 13:04:46 +01:00
 @@ -794,7 +794,7 @@
  endif
  
@@ -102,8 +141,8 @@ diff -urNd ../twin-0.4.6-r0/twin-0.4.6/makerules twin-0.4.6/makerules
  
  #
 diff -urNd ../twin-0.4.6-r0/twin-0.4.6/scripts/mkdep.c twin-0.4.6/scripts/mkdep.c
---- ../twin-0.4.6-r0/twin-0.4.6/scripts/mkdep.c        2003-03-27 08:29:48.000000000 +0000
-+++ twin-0.4.6/scripts/mkdep.c 2004-07-24 13:24:21.000000000 +0100
+--- ../twin-0.4.6-r0/twin-0.4.6/scripts/mkdep.c        2003-03-27 08:29:48 +00:00
++++ twin-0.4.6/scripts/mkdep.c 2004-07-27 13:04:46 +01:00
 @@ -172,8 +172,8 @@
        putchar('\n');
  }