python-pyqt: only apply patches for qreal on arm/mips machines
authorJeremy Lainé <jeremy.laine@m4x.org>
Thu, 26 Mar 2009 06:26:35 +0000 (07:26 +0100)
committerJeremy Lainé <jeremy.laine@m4x.org>
Thu, 26 Mar 2009 06:26:35 +0000 (07:26 +0100)
recipes/python/python-pyqt_4.4.3.bb

index 08a8fc6..8033bc5 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "GPL"
 DEPENDS = "sip-native python-sip"
 RDEPENDS = "python-core"
 SRCNAME = "pyqt"
-PR = "ml4"
+PR = "ml5"
 
 PYQT_OE_VERSION = "Qt_4_4_1"
 
@@ -16,13 +16,21 @@ SRC_URI = "\
   file://cross-compile.patch;patch=1 \
   file://01_configure.dpatch;patch=1 \
   file://02_htmllinks.dpatch;patch=1 \
-  file://03_qreal.dpatch;patch=1 \
-  file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1 \
   \
   file://assistantclient-fix.patch;patch=1 \
 "
 S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
 
+# arm and mips machines need some extra patches
+
+SRC_URI_append_arm = "\
+  file://03_qreal.dpatch;patch=1 \
+  file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+
+SRC_URI_append_mipsel = "\
+  file://03_qreal.dpatch;patch=1 \
+  file://04_qreal_api_fixes-for-4.4.3.dpatch;patch=1"
+
 inherit qt4x11 sip distutils-base
 
 PARALLEL_MAKE = ""