linux-omap, -pm: add patch to reset MUSB phy
authorKoen Kooi <koen@openembedded.org>
Thu, 5 Mar 2009 15:30:30 +0000 (16:30 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 5 Mar 2009 15:30:30 +0000 (16:30 +0100)
packages/linux/linux-omap-pm/usbttyfix.patch [new file with mode: 0644]
packages/linux/linux-omap-pm_git.bb
packages/linux/linux-omap/usbttyfix.patch [new file with mode: 0644]
packages/linux/linux-omap_2.6.28.bb

diff --git a/packages/linux/linux-omap-pm/usbttyfix.patch b/packages/linux/linux-omap-pm/usbttyfix.patch
new file mode 100644 (file)
index 0000000..997705a
--- /dev/null
@@ -0,0 +1,29 @@
+To get USB HOST mode working on USB OTG Port with USB TTY enabled U-boot
+
+Signed-off-by: Syed Mohammed Khasim <khasim@ti.com>
+---
+--- linux-2.6.git/drivers/usb/musb/omap2430.c  2009-01-19 22:42:18.000000000 +0530
++++ linux-2.6.git/drivers/usb/musb/omap2430.c  2009-02-19 12:45:22.000000000 +0530
+@@ -33,6 +33,7 @@
+ #include <linux/list.h>
+ #include <linux/clk.h>
+ #include <linux/io.h>
++#include <linux/i2c/twl4030.h>
+ #include <asm/mach-types.h>
+ #include <mach/hardware.h>
+@@ -233,6 +234,14 @@ int __init musb_platform_init(struct mus
+       omap_cfg_reg(AE5_2430_USB0HS_STP);
+ #endif
++      /* Reset MUSB Controller */
++      omap_writel(SOFTRST,OTG_SYSCONFIG);
++
++#if defined(CONFIG_TWL4030_USB)
++      /* Reset the TWL USB PHY */
++      twl4030_i2c_write_u8(TWL4030_MODULE_USB, 0x60, 0x4);
++#endif
++
+       musb->xceiv = *x;
+       musb_platform_resume(musb);
index 6ee2109..0da2b89 100644 (file)
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
 SRCREV = "65d02c2c7fe676369b7162459feec60268c7f4ba"
 
 PV = "2.6.28-pm2+gitr${SRCREV}"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm \
           file://defconfig"
@@ -47,6 +47,7 @@ SRC_URI_append = " \
            file://dss2.diff;patch=1 \
            file://register-all-OPPs.diff;patch=1 \
            file://add-cpufreq-for-omap3evm.diff;patch=1 \
+           file://usbttyfix.patch;patch=1 \
 "
 
 
diff --git a/packages/linux/linux-omap/usbttyfix.patch b/packages/linux/linux-omap/usbttyfix.patch
new file mode 100644 (file)
index 0000000..997705a
--- /dev/null
@@ -0,0 +1,29 @@
+To get USB HOST mode working on USB OTG Port with USB TTY enabled U-boot
+
+Signed-off-by: Syed Mohammed Khasim <khasim@ti.com>
+---
+--- linux-2.6.git/drivers/usb/musb/omap2430.c  2009-01-19 22:42:18.000000000 +0530
++++ linux-2.6.git/drivers/usb/musb/omap2430.c  2009-02-19 12:45:22.000000000 +0530
+@@ -33,6 +33,7 @@
+ #include <linux/list.h>
+ #include <linux/clk.h>
+ #include <linux/io.h>
++#include <linux/i2c/twl4030.h>
+ #include <asm/mach-types.h>
+ #include <mach/hardware.h>
+@@ -233,6 +234,14 @@ int __init musb_platform_init(struct mus
+       omap_cfg_reg(AE5_2430_USB0HS_STP);
+ #endif
++      /* Reset MUSB Controller */
++      omap_writel(SOFTRST,OTG_SYSCONFIG);
++
++#if defined(CONFIG_TWL4030_USB)
++      /* Reset the TWL USB PHY */
++      twl4030_i2c_write_u8(TWL4030_MODULE_USB, 0x60, 0x4);
++#endif
++
+       musb->xceiv = *x;
+       musb_platform_resume(musb);
index ff1c5d2..9824d7e 100644 (file)
@@ -12,7 +12,7 @@ DEFAULT_PREFERENCE_overo = "1"
 SRCREV = "79d042a081d3e467c735bb0d9569ed6296f85a3c"
 
 PV = "2.6.28"
-PR = "r13"
+PR = "r14"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;branch=omap-2.6.28;protocol=git \
           file://defconfig"
@@ -50,6 +50,7 @@ SRC_URI_append = " \
            file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
            file://0001-board-omap3beagle-set-i2c-3-to-100kHz.patch;patch=1 \
            file://add-resizer-driver.patch;patch=1 \
+           file://usbttyfix.patch;patch=1 \
 "