opie-alarm: adjust for the new filesystem layout
authorMichael Krelin <hacker@klever.net>
Sat, 7 Jul 2007 16:51:39 +0000 (16:51 +0000)
committerMichael Krelin <hacker@klever.net>
Sat, 7 Jul 2007 16:51:39 +0000 (16:51 +0000)
classes/opie.bbclass
packages/opie-alarm/opie-alarm/dirdefines.patch [new file with mode: 0644]
packages/opie-alarm/opie-alarm_cvs.bb

index c11cf0b..6324dbf 100644 (file)
@@ -21,7 +21,8 @@ DEPENDS_prepend = "${@["libopie2 ", ""][(bb.data.getVar('PN', d, 1) == 'libopie2
 
 # to be consistent, put all targets into workdir
 # NOTE: leave one space at the end, other files are expecting that
-EXTRA_QMAKEVARS_POST += "DESTDIR=${S} "
+EXTRA_QMAKEVARS_POST += " DESTDIR=${S} "
+EXTRA_QMAKEVARS_POST += " DEFINES+=OPIE_BINDIR='\"${bindir}\"' DEFINES+=OPIE_LIBDIR='\"${libdir}/opie/lib\"' DEFINES+=OPIE_QTDIR='\"${libdir}/opie\"' "
 
 # Opie standard TAG value
 TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
diff --git a/packages/opie-alarm/opie-alarm/dirdefines.patch b/packages/opie-alarm/opie-alarm/dirdefines.patch
new file mode 100644 (file)
index 0000000..ea1e686
--- /dev/null
@@ -0,0 +1,21 @@
+diff --git a/opiealarm.c b/opiealarm.c
+index 422865c..b948ef2 100644
+--- a/opiealarm.c
++++ b/opiealarm.c
+@@ -367,13 +367,13 @@ int resume ( int resuspend )
+                               
+                               setenv ( "LOGNAME", "root", 1 );
+                               setenv ( "HOME", "/root", 1 );
+-                              setenv ( "LD_LIBRARY_PATH", "/opt/QtPalmtop/lib", 1 );
+-                              setenv ( "QTDIR", "/opt/QtPalmtop", 1 );
++                              setenv ( "LD_LIBRARY_PATH", OPIE_LIBDIR, 1 );
++                              setenv ( "QTDIR", OPIE_QTDIR, 1 );
+                       
+                               remove_pidfile ( );
+                       
+                               // no need for system() since this process is no longer useful anyway                           
+-                              execv ( "/opt/QtPalmtop/bin/qcop", argv );
++                              execv ( OPIE_BINDIR "/qcop", argv );
+                               
+                               perror ( "exec for qcop failed" );
+                               return 5;
index b592736..2cdb067 100644 (file)
@@ -1,7 +1,8 @@
 require ${PN}.inc
 
 PV = "${OPIE_CVS_PV}"
-PR = "r2"
+PR = "r2.1"
 
 SRC_URI = "${HANDHELDS_CVS};module=opie/core/opiealarm \
-           file://01opiealarm "
+           file://01opiealarm \
+          file://dirdefines.patch;patch=1 "