Fix lib64 issue (SlugBug #219)
authorOyvind Repvik <nail@nslu2-linux.org>
Wed, 3 Aug 2005 02:59:03 +0000 (02:59 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 3 Aug 2005 02:59:03 +0000 (02:59 +0000)
packages/procps/procps-3.2.5/install.patch
packages/procps/procps_3.2.5.bb

index a05eec4..9f1ef69 100644 (file)
@@ -1,25 +1,27 @@
-*** procps-3.2.5/Makefile.orig Sun Jul 24 03:29:32 2005
---- procps-3.2.5/Makefile      Sun Jul 24 03:30:14 2005
-***************
-*** 211,220 ****
-  ###### install
-  
-  $(BINFILES) : all
-!      $(install) --mode a=rx $(notdir $@) $@
-  
-  $(MANFILES) : all
-!      $(install) --mode a=r $(notdir $@) $@
-  
-  install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
-       cd $(usr/bin) && $(ln_f) skill snice
---- 211,220 ----
-  ###### install
-  
-  $(BINFILES) : all
-!      $(install) -m 555 $(notdir $@) $@
-  
-  $(MANFILES) : all
-!      $(install) -m 444 $(notdir $@) $@
-  
-  install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
-       cd $(usr/bin) && $(ln_f) skill snice
+--- procps-3.2.5.virgin/Makefile       2005-01-26 05:55:26.000000000 +0100
++++ procps-3.2.5/Makefile      2005-08-03 04:55:26.346984488 +0200
+@@ -30,7 +30,10 @@
+ install  := install -D --owner 0 --group 0
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+-lib64    := lib$(shell [ -d /lib64 ] && echo 64)
++# lib64    := lib$(shell [ -d /lib64 ] && echo 64)
++
++# Equally lame hack to work around makefile lameness when the host arch is 64bit, but the target is not.
++lib64      := lib
+ usr/bin                  := $(DESTDIR)/usr/bin/
+ bin                      := $(DESTDIR)/bin/
+@@ -211,10 +214,10 @@
+ ###### install
+ $(BINFILES) : all
+-      $(install) --mode a=rx $(notdir $@) $@
++      $(install) -m 555 $(notdir $@) $@
+ $(MANFILES) : all
+-      $(install) --mode a=r $(notdir $@) $@
++      $(install) -m 444 $(notdir $@) $@
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+       cd $(usr/bin) && $(ln_f) skill snice
index 51e37a1..21b2783 100644 (file)
@@ -7,7 +7,7 @@ SECTION = "base"
 PRIORITY = "optional"
 MAINTAINER = "Inge Arnesen <inge.arnesen@gmail.com>"
 DEPENDS = "ncurses"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
            file://install.patch;patch=1 \