increase dvbapp PR.
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
index 021d589..bbf1f8a 100644 (file)
@@ -14,7 +14,7 @@ RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
        gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
        gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect gst-plugin-flv \
-       glibc-gconv-iso8859-15 ethtool"
+       glibc-gconv-iso8859-15 ethtool parted"
 
 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
@@ -76,8 +76,10 @@ RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat5
 RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 libgmp3 libmpfr1 opera-hbbtv"
 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-ng-blkid ntfs-3g dosfstools"
 
+RDEPENDS_enigma2-plugin-systemplugins-netdrive = "curlftpfs kernel-module-fuse libfuse2"
+
 PN = "enigma2"
-PR = "r65"
+PR = "r141"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
@@ -126,6 +128,8 @@ SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};t
           file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
+           file://enigma2_vuplus_fix_standby_name.patch;patch=1;pnum=1 \
+           file://enigma2_vuplus_fix_standby_name_skin.patch;patch=1;pnum=1 \
            file://MyriadPro-Regular.otf \
            file://MyriadPro-Semibold.otf \
            file://MyriadPro-SemiboldIt.otf \
@@ -134,12 +138,7 @@ SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};t
            file://number_key \
            "
 
-SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
-SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
-SRC_URI_append_vusolo2 = " \
-          file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1 \
-          file://enigma2_vuplus_1080p.patch;patch=1;pnum=1 \
-"
+
 
 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
 
@@ -152,9 +151,8 @@ SRC_URI_append_vuultimo = " \
 "
 
 SRC_URI_append_vuduo2 = " \
-           file://enigma2_choicebox_duo2.patch;patch=1;pnum=1 \
-           file://skin_user.xml \
-           file://vfd_icons \
+           file://skin_user_vuduo2.xml \
+           file://vfd_icons_vuduo2 \
 "
 
 def change_po():
@@ -230,9 +228,9 @@ do_install_append_vuultimo() {
 }
 
 do_install_append_vuduo2() {
-        install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -m 0755 ${WORKDIR}/skin_user_vuduo2.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
         install -d ${D}/usr/share/enigma2/vfd_icons/
-        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons_vuduo2/*.png ${D}/usr/share/enigma2/vfd_icons/
 }
 
 python populate_packages_prepend () {