surpport seeking the recorded video
[vuplus_openembedded] / conf / documentation.conf
index cd189b6..f1abee0 100644 (file)
@@ -1,6 +1,6 @@
 # this file holds documentation for known keys, possible values and
 # their meaning. Please update, correct and extend this documentation.
-# Mail your changes to oe@handhelds.org
+# Mail your changes to openembedded-devel@openembedded.org
 
 # conf/bitbake.conf
 PREFERRED_VERSION[doc] = 'Normally use it as PREFERRED_VERSION_package-name = "" to set the preferred \
@@ -34,10 +34,17 @@ TARGET_CC_ARCH[doc] = "FIXME"
 TARGET_FPU[doc] = "Floating point option (mostly for FPU-less systems), can be 'soft' or empty \
 for hardware floating point instructions."
 
+ASSUME_PROVIDED[doc] = "List of packages (recipes actually) which are assumed to be implicitly available.\
+ These packages won't be built by bitbake."
+ASSUME_SHLIBS[doc] = "List of shlib:package[_version] mappings. Useful for lib packages in ASSUME_PROVIDED,\
+ for which automatic shlib dependency tracking doesn't work."
+
 PACKAGE_ARCH[doc] = 'The architecture needed for using a resulting package. If you have \
 machine dependant configuration options in your bitbake file add a \
 PACKAGE_ARCH  = "${MACHINE_ARCH}" to the file.'
 
+PACKAGE_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
+PACKAGE_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
 
 DATE[doc] = "The date the build was started Ymd"
 TIME[doc] = "The time the build was started HMS"
@@ -55,7 +62,7 @@ PRIORITY[doc] = "Importance of package, default values are 'optional' or 'needed
 DESCRIPTION[doc] = "A small description of the package."
 LICENSE[doc] = "The license of the resulting package e.g. GPL"
 AUTHOR[doc] = "The author of the files installed."
-MAINTAINER[doc] = "Maintainer of the .bb file and the resulting package."
+MAINTAINER[doc] = "Distributions can put this in their .conf file to add their contact information into packages, this is not valid inside recipes"
 HOMEPAGE[doc] = "Homepage of the package e.g. http://www.project.net."
 
 
@@ -63,8 +70,9 @@ HOMEPAGE[doc] = "Homepage of the package e.g. http://www.project.net."
 GROUP_dependencies[doc] = "The keys in this group influence the dependency handling of BitBake \
 and the resulting packages."
 DEPENDS[doc]  = "Build time dependencies, things needed to build the package. @group dependencies"
-RDEPENDS[doc] = "Run time dependencies, things needed for a given package to run. @group dependencies"
-PROVIDES[doc] = "Names for additional dependencies that this package will provide. @group dependencies"
+RDEPENDS[doc] = "Run time dependencies, things needed for a given package to run.  This is used to populate the ipkg:Depends field. @group dependencies"
+PROVIDES[doc] = "Names for additional build time dependencies that this package will provide. @group dependencies"
+RPROVIDES[doc] = "Names for additional run time dependencies that this package will provide.  This is used to populate the ipkg:Provides field. @group dependencies"
 
 
 # packaging
@@ -82,6 +90,7 @@ GROUP_fetcher[doc] = "The key highly influence the fetcher implementations."
 DL_DIR[doc] = "The directory where tarballs will be stored. @group fetcher"
 CVSDIR[doc] = "The directory where cvs checkouts will be stored in. @group fetcher"
 GITDIR[doc] = "The directory where git clones will be stored. @group fetcher"
+SVNDIR[doc] = "The directory where subversion checkouts will be stored. @group fetcher"
 
 STAMP[doc]   = "The directory that holds files to keep track of what was built."
 WORKDIR[doc] = "The directory where a concrete package will be unpacked and built."
@@ -92,5 +101,44 @@ ENABLE_BINARY_LOCALE_GENERATION[doc] = "Enable the use of qemu to generate local
 
 PCMCIA_MANAGER[doc] = "Specify which package(s) to install to handle PCMCIA slots (usually pcmcia-cs or pcmciautils)."
 
+SYSVINIT_ENABLED_GETTYS[doc] = "Specify which VTs should be running a getty, the default is 1"
+
+FEED_URIS[doc] = "List of ipkg feed records to put into generated image."
+FEED_DEPLOYDIR_BASE_URI[doc] = "Allow to serve ipk deploy dir as an adhoc feed (bogofeed). Set to base URL of the dir as exported by HTTP. Set of adhoc feed configs will be generated in image."
+
+# insane bbclass
+QA_LOG[doc] = "Enable logging of QA errors to log.qa_package. Default is not to log."
+
 # palmtop build class
 PALMTOP_USE_MULTITHREADED_QT[doc] = "Set to yes, if you want to build qt apps with CONFIG+=thread"
+
+COMPATIBLE_HOST[doc] = "A regular expression which matches the HOST_SYS names supported by the package/file. Failure to match will cause the file to be skipped by the parser."
+COMPATIBLE_MACHINE[doc] = "A regular expression which matches the MACHINES support by the package/file. Failure to match will cause the file to be skipped by the parser."
+
+SOURCE_MIRROR_FETCH[doc] = "Switch marking build as source fetcher. Used to skip COMPATIBLE_* checking."
+SOURCE_MIRROR_URL[doc] = "URL to source mirror which will be used before fetching from original SRC_URI."
+
+BBINCLUDELOGS[doc] = "Boolean switch to get log printed on failure."
+BBINCLUDELOGS_LINES[doc] = "Amount of log lines printed on failure."
+
+
+# seppuku bbclass
+SEPPUKU_AUTOBUILD[doc] = "This is an autobuild, broken packages are cleaned automatically. Don't define this at all if this is not an autobuild"
+SEPPUKU_USER[doc]     = "The login-name for the bugzilla account"
+SEPPUKU_PASS[doc]     = "The password for this account"
+#SEPPUKU_LOGIN         = "http://bugs.openembedded.net/query.cgi?"
+SEPPUKU_LOGIN[doc]    = "path to the login script of the bugzilla, note the ? at the end"
+#SEPPUKU_QUERY         = "http://bugs.openembedded.net/buglist.cgi"
+SEPPUKU_QUERY[doc]    = "The query script of the bugzilla"
+#SEPPUKU_NEWREPORT     = "http://bugs.openembedded.net/post_bug.cgi?bug_file_loc=http%3A%2F%2F&version=unspecified&priority=P2&bug_severity=normal&op_sys=Linux&rep_platform=Other&"
+SEPPUKU_NEWREPORT[doc]= "This is the url used to create a new bug report, note the defaults for version and priority and more, and the trailing &"
+#SEPPUKU_ADDCOMMENT     = "http://bugs.openembedded.net/process_bug.cgi?bug_file_loc=http%3A%2F%2F&version=unspecified&longdesclength=2&priority=P2&bug_severity=normal&op_sys=Linux&rep_platform=Other&"
+SEPPUKU_ADDCOMMENT[doc]= "The url used to reopen bug reports and to add another new comment"
+#SEPPUKU_ATTACHMENT = "http://bugs.openembedded.net/attachment.cgi"
+SEPPUKU_ATTACHMENT[doc] = "The url used to create attachments."
+
+
+#SEPPUKU_PRODUCT       = "Openembedded"
+SEPPUKU_PRODUCT[doc]  = "The product inside the bugtracker"
+#SEPPUKU_COMPONENT     = "build"
+SEPPUKU_COMPONENT[doc]= "The component inside the bugtracker"