fb32295e208f90cf03f7ec7d074c5ba016e13a0e
[vuplus_openembedded] / recipes / tasks / task-vuplus-wlan.bb
1 DESCRIPTION = "Vuplus: W-LAN Task for the Vuplus Distribution"
2 SECTION = "vuplus/base"
3 LICENSE = "MIT"
4 PR = "r3"
5
6 inherit task
7
8 #
9 # task-vuplus-wlan
10 #
11 DESCRIPTION_${PN} = "Vuplus: W-LAN Support"
12 DEPENDS_${PN} = "enigma2-plugins"
13 RDEPENDS_${PN} = "\
14   enigma2-plugin-systemplugins-wirelesslan \
15   wireless-tools \
16   wpa-supplicant \
17 "
18
19 WLAN_CRYPTO_MODULES = "\
20   kernel-module-aes-generic \
21   kernel-module-arc4 \
22   kernel-module-ecb \
23   kernel-module-cryptomgr \
24   kernel-module-crypto-hash \
25   kernel-module-aead \
26   kernel-module-pcompress \
27   kernel-module-crypto-blkcipher \
28   kernel-module-crypto-algapi \
29 "
30
31 WLAN_PCI_MODULES = "\
32   kernel-module-ath5k \
33 "
34
35 WLAN_USB_MODULES = "\
36   kernel-module-rt73usb \
37   kernel-module-zd1211rw \
38   rt73-firmware \
39   zd1211-firmware \
40 "
41
42 WLAN_USB_MODULES_LEGACY = "\
43   zd1211b \
44   wlan-rt73 \
45   r8712u \
46   rt3070 \
47 "
48
49 RDEPENDS_${PN}_append_bm750 = "\
50   ${@base_contains('PREFERRED_VERSION_linux-bm750', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
51 "
52
53 RDEPENDS_${PN}_append_vusolo = "\
54   ${@base_contains('PREFERRED_VERSION_linux-vusolo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
55 "
56
57 RDEPENDS_${PN}_append_vuuno = "\
58   ${@base_contains('PREFERRED_VERSION_linux-vuuno', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
59 "
60
61 RDEPENDS_${PN}_append_vuultimo = "\
62   ${@base_contains('PREFERRED_VERSION_linux-vuultimo', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
63 "
64
65 PACKAGE_ARCH = "${MACHINE_ARCH}"
66