2fe48ea8722c8bc000829d48193dc48ee018e055
[vuplus_openembedded] / recipes / mml-widget / gtkmathview_0.8.0.bb
1 LICENSE = "GPL"
2 HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
3 DEPENDS = "t1lib gtk+ popt libxslt libxml2"
4
5 SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
6            file://mathview-gcc43x.diff;patch=1 \
7           "
8
9 inherit autotools 
10 AUTOTOOLS_STAGE_PKGCONFIG = 1
11
12 EXTRA_OECONF = "--disable-binreloc"
13
14 do_configure_prepend() {
15         sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
16 }
17
18 do_stage() {
19         autotools_stage_all
20         for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
21                 sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
22         done    
23 }
24