926da109bb5ef31f88be1557d51128c2da7b3e3c
[vuplus_openembedded] / recipes / linux / linux-dm8000_2.6.18.bb
1 require linux-opendreambox-2.6.18.inc
2
3 PR="${PR_INC}.0"
4
5 RDEPENDS += "dreambox-secondstage (>=83)"
6
7 SRC_URI += "\
8         file://linux-2.6.18-disable-unneeded-uarts.patch;patch=1 \
9         file://linux-2.6.18-dm8000-nand-smp-fix.patch;patch=1 \
10         file://linux-2.6.18-use-full-flash.patch;patch=1 \
11         file://linux-2.6.18-big-summary.patch;patch=1 \
12 "
13
14 pkg_preinst_kernel-image_dm8000 () {
15         if [ -z "$D" ]; then
16                 mountpoint -q /boot && mount -o rw,remount /boot;
17                 if grep -q '^mtd3: 03c00000 ' /proc/mtd && ! grep -q '^legacy_flash_mapping=' /boot/secondstage.conf; then
18                         echo "enable legacy flash mapping in secondstage.conf";
19                         echo "legacy_flash_mapping=1;" >> /boot/secondstage.conf;
20                 fi;
21         fi;
22 }