0b64e13593a6d716bd1919703a704cab0d922f30
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
7         hostap-daemon bridge-utils mpfr gmp tslib opera-hbbtv util-linux-ng ntfs-3g dosfstools "
8 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
9         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
10         python-pickle gst-plugin-app gst-plugin-fragmented \
11         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
12         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
13         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
14         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
15         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
16         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect gst-plugin-flv \
17         glibc-gconv-iso8859-15 ethtool"
18
19 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
20 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
21 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
22 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
23 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
24
25 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
27 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
33 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
34 RDEPENDS_append_vuduo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
35 RDEPENDS_append_vusolo2 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
36 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
37
38 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
39 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
40 #DEPENDS += "enigma2-plugins"
41 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
42
43 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
44 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
45 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
46 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
47 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
48 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
49 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
50 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
51 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
52 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
53 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
54 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
55 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
56 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
57 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
58 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
59 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
60 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
61 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
62 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
63 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
64 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
65 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
66 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
67 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
68 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
69 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
70 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
71 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
72 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
73 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugin-rtmp "
74 RDEPENDS_enigma2-plugin-extensions-dlnabrowser = "djmount fuse-utils libfuse2 libupnp3 kernel-module-fuse "
75 RDEPENDS_enigma2-plugin-extensions-dlnaserver = "minidlna libexif12 libavformat52 libavutil50 libavcodec52 libgsm1 libmp3lame0 libschroedinger-1.0-0 libtheora0 liboil"
76 RDEPENDS_enigma2-plugin-extensions-hbbtv = "tslib-conf libts-1.0-0 libsysfs2 libgmp3 libmpfr1 opera-hbbtv"
77 RDEPENDS_enigma2-plugin-systemplugins-devicemanager = "util-linux-ng-blkid ntfs-3g dosfstools"
78
79 PN = "enigma2"
80 PR = "r76"
81
82 SRCDATE = "20110922"
83 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
84 #SRCDATE is NOT used by git to checkout a specific revision
85 #but we need it to build a ipk package version
86 #when you like to checkout a specific revision of e2 you need
87 #have to specify a commit id or a tag name in SRCREV
88
89 # if you want experimental use
90 ####################################################
91 BRANCH = "experimental"
92 PV = "experimental-git${SRCDATE}"
93 #SRCREV = ""
94 ####################################################
95
96 # if you want a 2.7-based release, use
97 ####################################################
98 #BRANCH="2.7"
99 #PV = "2.7git${SRCDATE}"
100 # if you want 2.7.0 use
101 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
102 ####################################################
103
104 # if you want a vuplus release, use
105 ####################################################
106 #BRANCH_vuplus = "vuplus"
107 #PV_vuplus = "2.8git${SRCDATE}"
108 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
109 ####################################################
110
111 #if you want a vuplus experimental, use
112 ####################################################
113 BRANCH_vuplus = "vuplus_experimental"
114 PV_vuplus = "experimental-git${SRCDATE}"
115 SRCREV_vuplus = ""
116 ####################################################
117
118 #SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
119 #SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
120
121 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
122
123 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
124            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
125            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
126            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
127            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
128            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
129            file://MyriadPro-Regular.otf \
130            file://MyriadPro-Semibold.otf \
131            file://MyriadPro-SemiboldIt.otf \
132            file://750S \
133            file://Vu_HD \
134            file://number_key \
135            "
136
137 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
138
139 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
140
141 SRC_URI_append_vuultimo = " \
142            file://analog.ttf \
143            file://skin_user.xml \
144            file://vfd_icons \
145 "
146
147 SRC_URI_append_vuduo2 = " \
148            file://skin_user_vuduo2.xml \
149            file://vfd_icons_vuduo2 \
150 "
151
152 def change_po():
153         import os
154         try:
155                 os.system("find ./ -name \"*.po\" > ./po_list")
156                 os.system("find ./ -name \"*.pot\" >> ./po_list")
157                 po_list = []
158                 po_list = open('po_list','r+').readlines()
159                 for x in po_list:
160                         changeword(x)
161                 os.system('rm po_list')
162         except:
163                 print 'word patch error '
164                 return
165
166 def changeword(file):
167         fn = file[:-1]
168         fnn = file[:-1]+'_n'
169         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
170         os.system(cmd)
171         cmd1 = "mv "+fnn+" "+fn
172         os.system(cmd1)
173
174 do_unpack_append(){
175         change_po()
176 }
177
178 S = "${WORKDIR}/git"
179
180 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
181 FILES_${PN}-meta = "${datadir}/meta"
182 PACKAGES += "${PN}-meta"
183 PACKAGE_ARCH = "${MACHINE_ARCH}"
184
185 inherit autotools pkgconfig
186
187
188 do_compile_prepend_vuplus() {
189         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
190         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
191         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
192         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
193         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
194         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
195         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
196         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
197         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
198         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
199         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
200         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
201         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
202         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
203         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
204 }
205
206 EXTRA_OECONF = " \
207         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
208         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
209         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
210         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
211         BUILD_SYS=${BUILD_SYS} \
212         HOST_SYS=${HOST_SYS} \
213         STAGING_INCDIR=${STAGING_INCDIR} \
214         STAGING_LIBDIR=${STAGING_LIBDIR} \
215 "
216
217 do_install_append_vuultimo() {
218         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
219         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
220         install -d ${D}/usr/share/enigma2/vfd_icons/
221         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
222 }
223
224 do_install_append_vuduo2() {
225         install -m 0755 ${WORKDIR}/skin_user_vuduo2.xml ${D}/usr/share/enigma2/defaults/skin_user.xml
226         install -d ${D}/usr/share/enigma2/vfd_icons/
227         install -m 0755 ${WORKDIR}/vfd_icons_vuduo2/*.png ${D}/usr/share/enigma2/vfd_icons/
228 }
229
230 python populate_packages_prepend () {
231         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
232
233         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
234 }
235
236 RCONFLICTS_${PN} = "dreambox-keymaps"
237 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
238
239 # workaround for opkg <= 0.1.7+svnr455-r19.1
240 pkg_preinst_${PN} () {
241         if [ "x$D" != "x" ]; then
242                 exit 1
243         fi
244         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
245                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
246         fi
247 }
248 pkg_postinst_${PN} () {
249         if [ "x$D" != "x" ]; then
250                 exit 1
251         fi
252         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
253                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
254         fi
255 }