2f1624ede225efc569c9aab2d31ae2998cb21ad4
[vuplus_openembedded] / packages / samba / samba_3.2.5.bb
1 require samba.inc
2 inherit update-rc.d
3
4 PR = "r7"
5
6 SRC_URI += "file://config-lfs.patch;patch=1 \
7             file://quota.patch;patch=1;pnum=0 \
8             file://config-h.patch;patch=1 \
9             file://init \
10             file://smb.conf \
11                 "
12
13 #          file://cifs.patch;patch=1 \
14
15 INITSCRIPT_NAME = "samba"
16 # No dependencies, goes in at level 20 (NOTE: take care with the
17 # level, later levels put the shutdown later too - see the links
18 # in rc6.d, the shutdown must precede network shutdown).
19 INITSCRIPT_PARAMS = "defaults"
20 CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
21 CONFFILES_${PN}_opendreambox = ""
22
23 # The file system settings --foodir=dirfoo and overridden unconditionally
24 # in the samba config by --with-foodir=dirfoo - even if the --with is not
25 # specified!  Fix that here.  Set the privatedir to /etc/samba/private.
26 EXTRA_OECONF += "\
27         SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
28         samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
29         samba_cv_struct_timespec=yes \
30         linux_getgrouplist_ok=no \
31         samba_cv_HAVE_BROKEN_GETGROUPS=no \
32         samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
33         ac_cv_path_KRB5CONFIG=no \
34         samba_cv_have_setresuid=yes \
35         samba_cv_have_setresgid=yes \
36         --with-configdir=${sysconfdir}/samba \
37         --with-privatedir=${sysconfdir}/samba/private \
38         --with-lockdir=${localstatedir}/lock \
39         --with-piddir=${localstatedir}/run \
40         --with-logfilebase=${localstatedir}/log \
41         --with-libdir=${libdir} \
42         --with-mandir=${mandir} \
43         --with-swatdir=${datadir}/swat \
44         "
45
46 do_configure() {
47         oe_runconf
48 }
49
50 do_install_append() {
51         install -d "${D}/var/log/samba"
52         install -d "${D}${sysconfdir}/init.d"
53         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
54         install -d "${D}${sysconfdir}/samba"
55         install -c -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
56         install -d ${D}/var/spool/samba
57 }
58
59 PACKAGES =+ "swat"
60
61 FILES_swat       = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
62 FILES_${PN}     += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat \
63                     ${libdir}/auth/*.so ${libdir}/security/*.so"
64 FILES_${PN}-dbg += "${libdir}/vfs/.debug/*.so ${libdir}/charset/.debug/*.so \
65                     ${libdir}/auth/.debug/*.so ${libdir}/security/.debug/*.so"
66
67 #
68 # bug fix for samba.inc:
69 FILES_cifs-doc += "${mandir}/man8/mount.cifs.8"