fix virtual keyboard bug.
[vuplus_dvbapp] / lib / driver / Makefile.am
old mode 100644 (file)
new mode 100755 (executable)
index 88d9bec..a781229
@@ -4,6 +4,9 @@ AM_CPPFLAGS = \
        -include Python.h \
        -include $(top_builddir)/enigma2_config.h
 
+AM_CXXFLAGS = \
+       $(LIBSDL_CFLAGS)
+
 noinst_LIBRARIES = libenigma_driver.a
 
 libenigma_driver_a_SOURCES = \
@@ -13,7 +16,8 @@ libenigma_driver_a_SOURCES = \
        rc.cpp \
        rcconsole.cpp \
        rcinput.cpp \
-       rfmod.cpp
+       rfmod.cpp \
+       hdmi_cec.cpp
 
 driverincludedir = $(pkgincludedir)/lib/driver
 driverinclude_HEADERS = \
@@ -26,4 +30,11 @@ driverinclude_HEADERS = \
        rcdbox.h \
        rcdreambox2.h \
        rcinput.h \
-       rfmod.h
+       rfmod.h \
+       hdmi_cec.h
+
+if HAVE_LIBSDL
+libenigma_driver_a_SOURCES += \
+       rcsdl.cpp \
+       rcsdl.h
+endif