build and link static libraries without libtool
[vuplus_dvbapp] / lib / components / Makefile.am
index 70bd8b6..e873e52 100644 (file)
@@ -1,7 +1,13 @@
-INCLUDES = \
-       -I$(top_srcdir)/include
+AM_CPPFLAGS = \
+       -I$(top_srcdir) \
+       -I$(top_srcdir)/include \
+       -include Python.h \
+       -include $(top_builddir)/enigma2_config.h
 
 noinst_LIBRARIES = libenigma_components.a
 
-libenigma_components_a_SOURCES = scan.cpp listboxepg.cpp file_eraser.cpp
-       
\ No newline at end of file
+libenigma_components_a_SOURCES = \
+       file_eraser.cpp \
+       file_eraser.h \
+       scan.cpp \
+       scan.h