Merge branch 'vuplus-1.6' of code.vuplus.com:/opt/repository/openembedded into vuplus-1.6
authorChang.H.S <jhs@dev3>
Thu, 24 Nov 2011 08:43:10 +0000 (17:43 +0900)
committerChang.H.S <jhs@dev3>
Thu, 24 Nov 2011 08:43:10 +0000 (17:43 +0900)
recipes/enigma2/enigma2.bb
recipes/enigma2/enigma2/vuplus/analog.ttf [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/orbitron-medium.ttf [deleted file]
recipes/enigma2/enigma2/vuplus/skin_user.xml
recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_crypt.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_dolby.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_format.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_rec.png [new file with mode: 0755]
recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_txt.png [new file with mode: 0755]

index fbebca5..85c2780 100644 (file)
@@ -131,8 +131,10 @@ SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
 
 SRC_URI_append_vuultimo = " \
-           file://orbitron-medium.ttf \
-           file://skin_user.xml"
+           file://analog.ttf \
+           file://skin_user.xml \
+           file://vfd_icons \
+"
 
 def change_po():
         import os
@@ -200,8 +202,10 @@ EXTRA_OECONF = " \
 "
 
 do_install_append_vuultimo() {
-        install -m 0755 ${WORKDIR}/orbitron-medium.ttf ${D}/usr/share/fonts/
+        install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -d ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
 }
 
 python populate_packages_prepend () {
diff --git a/recipes/enigma2/enigma2/vuplus/analog.ttf b/recipes/enigma2/enigma2/vuplus/analog.ttf
new file mode 100755 (executable)
index 0000000..ed50ae9
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/analog.ttf differ
diff --git a/recipes/enigma2/enigma2/vuplus/orbitron-medium.ttf b/recipes/enigma2/enigma2/vuplus/orbitron-medium.ttf
deleted file mode 100644 (file)
index 88499ff..0000000
Binary files a/recipes/enigma2/enigma2/vuplus/orbitron-medium.ttf and /dev/null differ
index 266779d..643defa 100644 (file)
 <skin>
        <fonts>
-               <font filename="orbitron-medium.ttf" name="VFD" scale="100"/>
+               <font filename="analog.ttf" name="VFD" scale="100"/>
        </fonts>
        <screen name="InfoBarSummary" position="0,0" size="256,64" id="1">
-               <widget source="session.CurrentService" render="Label" position="6,0" size="120,49" font="VFD;15" halign="center" valign="center" >
+               <widget source="session.CurrentService" render="Label" position="0,7" size="143,48" font="VFD;24" halign="center" valign="center" >
                        <convert type="ServiceName">Name</convert>
                </widget>
-               <widget source="session.Event_Now" render="Progress" position="5,50" size="120,14" borderWidth="1">
+               <widget source="session.Event_Now" render="Progress" position="0,59" size="143,5" borderWidth="1">
                        <convert type="EventTime">Progress</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,46" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
         </screen>
         <screen name="ChannelSelection_summary" position="0,0" size="256,64" id="1">
-               <widget source="session.CurrentService" render="Label" position="6,0" size="120,49" font="VFD;16" halign="center" valign="center" >
+               <widget source="parent.ServiceEvent" render="Label" position="0,7" size="143,48" font="VFD;24" halign="center" valign="center" >
                        <convert type="ServiceName">Name</convert>
                </widget>
-               <widget source="session.Event_Now" render="Progress" position="5,50" size="120,14" borderWidth="1">
+               <widget source="session.Event_Now" render="Progress" position="0,59" size="143,5" borderWidth="1">
                        <convert type="EventTime">Progress</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,44" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
        </screen>
        <screen name="InfoBarMoviePlayerSummary" position="0,0" size="256,64" id="1">
-               <widget source="session.CurrentService" render="Label" position="6,0" size="120,48" font="VFD;16" halign="center" valign="center" >
+               <widget source="session.CurrentService" render="Label" position="0,7" size="143,48" font="VFD;24" halign="center" valign="center" >
                        <convert type="ServiceName">Name</convert>
                </widget>
-               <widget source="session.CurrentService" render="Progress" position="5,50" size="120,14" borderWidth="1">
+               <widget source="session.CurrentService" render="Progress" position="0,59" size="143,5" borderWidth="1">
                        <convert type="ServicePosition">Position</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,44" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
        </screen>
+       <screen name="ChoiceBox_summary" position="0,0" size="256,64" id="1">
+               <widget source="parent.summary_list" render="Label" position="6,0" size="244,64" font="Regular;12" />
+       </screen>
+       <screen name="MessageBox_summary" position="0,0" size="256,64" id="1">
+               <widget source="parent.Text" render="Label" position="6,0" size="244,45" font="Regular;15" halign="center" valign="center" />
+               <widget source="parent.selectedChoice" render="Label" position="6,46" size="244,18" font="Regular;18" halign="center" valign="center" />
+       </screen>
        <screen name="MenuSummary" position="0,0" size="256,64" id="1">
-               <widget source="parent.title" render="Label" position="6,0" size="120,32" font="VFD;14" halign="center" valign="center"/>
-               <widget source="parent.menu" render="Label" position="6,32" size="120,32" font="VFD;15" halign="center" valign="center">
+               <widget source="parent.title" render="Label" position="0,0" size="143,32" font="VFD;18" halign="center" valign="center"/>
+               <widget source="parent.menu" render="Label" position="0,32" size="143,32" font="VFD;18" halign="center" valign="center">
                        <convert type="StringListSelection" />
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,44" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
        </screen>
-       <screen name="ServiceScanSummary" position="0,0" size="132,64" id="1">
-               <widget name="Title" position="6,4" size="120,42" font="VFD;15" transparent="1" />
-               <widget name="Service" position="6,22" size="120,26" font="VFD;12" transparent="1" />
-               <widget name="scan_progress" position="6,50" zPosition="1" borderWidth="1" size="56,12" backgroundColor="dark" />
+       <screen name="ServiceScanSummary" position="0,0" size="256,64" id="1">
+               <widget name="Title" position="0,0" size="256,26" font="VFD;20" transparent="1" />
+               <widget name="Service" position="0,30" size="256,30" font="VFD;15" transparent="1" />
+               <widget name="scan_progress" position="0,59" zPosition="1" borderWidth="1" size="143,5" backgroundColor="dark" />
        </screen>
        <screen name="SetupSummary" position="0,0" size="256,64" id="1">
-               <widget source="SetupTitle" render="Label" position="6,0" size="120,16" font="VFD;12" />
-               <widget source="SetupEntry" render="Label" position="6,16" size="120,32" font="VFD;12" />
-               <widget source="SetupValue" render="Label" position="6,48" size="120,16" font="VFD;12" />
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="SetupTitle" render="Label" position="6,0" size="143,16" font="VFD;16" />
+               <widget source="SetupEntry" render="Label" position="6,16" size="143,32" font="VFD;14" />
+               <widget source="SetupValue" render="Label" position="6,48" size="143,16" font="VFD;14" />
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,44" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
        </screen>
        <screen name="StandbySummary" position="0,0" size="256,64" id="1">
-               <widget source="global.CurrentTime" render="Label" position="132,45" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="20,22" size="113,32" font="VFD;40" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="global.CurrentTime" render="Label" position="135,20" zPosition="1" size="32,20" font="VFD;20" valign="center" transparent="1">
+                       <convert type="ClockToText">Format:%S</convert>
+               </widget>
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
        </screen>
        <screen name="SimpleSummary" position="0,0" size="256,64" id="1">
-               <widget source="parent.Title" render="Label" position="6,0" size="120,64" font="VFD;15" halign="center" valign="center" />
-               <widget source="global.CurrentTime" render="Label" position="132,44" size="90,20" font="VFD;26" halign="right" valign="top" transparent="1">
+               <widget source="parent.Title" render="Label" position="0,0" size="143,64" font="VFD;20" halign="center" valign="center" />
+               <widget source="global.CurrentTime" render="Label" position="180,44" size="58,20" font="VFD;20" halign="right" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%H:%M</convert>
                </widget>
-               <widget source="global.CurrentTime" render="Label" position="224,44" zPosition="1" size="30,19" font="VFD;15" valign="top" transparent="1">
+               <widget source="global.CurrentTime" render="Label" position="241,44" zPosition="1" size="15,10" font="VFD;10" valign="center" transparent="1">
                        <convert type="ClockToText">Format:%S</convert>
                </widget>
-               <widget source="session.RecordState" render="Pixmap" pixmap="750S/icons/icon_rec.png" position="132,5"  size="31,15">
+               <widget source="session.RecordState" render="Pixmap" pixmap="vfd_icons/vfd_icon_rec.png" position="155,0"  size="28,12">
                        <convert type="ConditionalShowHide" />
                </widget>       
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_crypt.png" position="164,5"  size="11,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_crypt.png" position="186,0"  size="10,12">
                        <convert type="ServiceInfo">IsCrypted</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_txt.png" position="176,5" size="18,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_txt.png" position="199,0" size="14,12">
                        <convert type="ServiceInfo">HasTelext</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="Vu_HD/icons/icon_format.png" position="195,5" size="28,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_format.png" position="216,0" size="21,12">
                        <convert type="ServiceInfo">IsWidescreen</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
-               <widget source="session.CurrentService" render="Pixmap" pixmap="750S/icons/icon_dolby.png" position="224,5" size="32,15">
+               <widget source="session.CurrentService" render="Pixmap" pixmap="vfd_icons/vfd_icon_dolby.png" position="240,0" size="16,12">
                        <convert type="ServiceInfo">IsMultichannel</convert>
                        <convert type="ConditionalShowHide" />
                </widget>
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_crypt.png b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_crypt.png
new file mode 100755 (executable)
index 0000000..e722ee2
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_crypt.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_dolby.png b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_dolby.png
new file mode 100755 (executable)
index 0000000..e15fce5
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_dolby.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_format.png b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_format.png
new file mode 100755 (executable)
index 0000000..382637e
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_format.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_rec.png b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_rec.png
new file mode 100755 (executable)
index 0000000..061d63c
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_rec.png differ
diff --git a/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_txt.png b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_txt.png
new file mode 100755 (executable)
index 0000000..9df696c
Binary files /dev/null and b/recipes/enigma2/enigma2/vuplus/vfd_icons/vfd_icon_txt.png differ