libdisplaymigration: Makefile fix - don't strip on install
authorAndrea Adami <andrea.adami@gmail.com>
Fri, 1 May 2009 13:11:05 +0000 (15:11 +0200)
committerAndrea Adami <andrea.adami@gmail.com>
Fri, 1 May 2009 13:11:05 +0000 (15:11 +0200)
recipes/libdisplaymigration/files/makefile-fix.patch [new file with mode: 0644]
recipes/libdisplaymigration/libdisplaymigration_0.28.bb
recipes/libdisplaymigration/libdisplaymigration_0.99.bb

diff --git a/recipes/libdisplaymigration/files/makefile-fix.patch b/recipes/libdisplaymigration/files/makefile-fix.patch
new file mode 100644 (file)
index 0000000..5a79ab2
--- /dev/null
@@ -0,0 +1,11 @@
+--- /tmp/Makefile      2005-02-28 20:32:13.000000000 +0100
++++ libdisplaymigration-0.99/Makefile  2009-05-01 14:26:17.000000000 +0200
+@@ -36,7 +36,7 @@
+ install-program: $(SONAME)
+       install -d $(DESTDIR)$(PREFIX)/lib
+-      install -s $(SONAME) $(DESTDIR)$(PREFIX)/lib/$(SONAME)
++      install $(SONAME) $(DESTDIR)$(PREFIX)/lib/$(SONAME)
+ install-devel:
+       for i in $(HEADERS); do install -m 644 -D $$i $(DESTDIR)$(PREFIX)/include/$$i; done
index e92cf57..8f85dff 100644 (file)
@@ -7,6 +7,8 @@ PR = "r1"
 
 inherit pkgconfig gpe
 
+SRC_URI += "file://makefile-fix.patch;patch=1"
+
 headers = "displaymigration.h auth.h crypt.h"
 
 do_install() {
index 0563ba3..033005d 100644 (file)
@@ -7,6 +7,8 @@ PR = "r0"
 
 inherit pkgconfig gpe
 
+SRC_URI += "file://makefile-fix.patch;patch=1"
+
 headers = "displaymigration.h auth.h crypt.h"
 
 do_install() {