wireshark/tshark: extracted common parts
authorSergey Lapin <slapin@ossfans.org>
Thu, 29 Jan 2009 13:23:36 +0000 (16:23 +0300)
committerSergey Lapin <slapin@ossfans.org>
Mon, 16 Feb 2009 07:10:37 +0000 (10:10 +0300)
packages/wireshark/tshark_0.99.4.bb
packages/wireshark/wireshark.inc [new file with mode: 0644]
packages/wireshark/wireshark_0.99.4.bb

index e63a0c2..b7fe2af 100644 (file)
@@ -1,23 +1,5 @@
 DESCRIPTION = "tshark is the text based verion of wireshark - a popular network protocol analyzer"
-HOMEPAGE = "http://www.ethereal.com"
-SECTION = "network"
-LICENSE = "GPL"
-DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
-           file://use-our-lemon.patch;patch=1 \
-           file://acinclude-net-snmp-fix.patch;patch=1 \
-           file://libtool-fix.patch;patch=1 \
-          file://no-host-includes.patch;patch=1"
-
-S=${WORKDIR}/wireshark-${PV}
-
-inherit autotools
+require wireshark.inc
 
 EXTRA_OECONF = "--disable-wireshark --with-net-snmp=${STAGING_DIR_HOST}${layout_bindir}/net-snmp-config"
 
-do_compile_prepend() {
-       ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
-       oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
-}
-
diff --git a/packages/wireshark/wireshark.inc b/packages/wireshark/wireshark.inc
new file mode 100644 (file)
index 0000000..13715ea
--- /dev/null
@@ -0,0 +1,20 @@
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
+           file://use-our-lemon.patch;patch=1 \
+           file://acinclude-net-snmp-fix.patch;patch=1 \
+           file://libtool-fix.patch;patch=1 \
+          file://no-host-includes.patch;patch=1"
+
+S=${WORKDIR}/wireshark-${PV}
+
+inherit autotools
+
+do_compile_prepend() {
+       ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
+       oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+}
+
index 357f264..f4c90fc 100644 (file)
@@ -1,23 +1,9 @@
-DESCRIPTION = "Ethereal is the world's most popular network protocol analyzer"
-HOMEPAGE = "http://www.ethereal.com"
-SECTION = "x11/network"
-LICENSE = "GPL"
-DEPENDS = "perl-native gtk+ gnutls libpcap pcre expat"
+DESCRIPTION = "Wireshark is the world's most popular network protocol analyzer"
+require wireshark.inc
+DEPENDS += "gtk+"
 
 PR = "r1"
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.bz2 \
-           file://use-our-lemon.patch;patch=1 \
-           file://acinclude-net-snmp-fix.patch;patch=1 \
-           file://libtool-fix.patch;patch=1 \
-          file://no-host-includes.patch;patch=1"
-
-inherit autotools
-
-do_compile_prepend() {
-       ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
-       oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
-}
 
 FILES_${PN}-dbg += "${libdir}/wireshark/plugins/${PV}/.debug"