rename packages/ to recipes/ per earlier agreement
[vuplus_openembedded] / recipes / unifdef / unifdef-native_2.6.18+git.bb
diff --git a/recipes/unifdef/unifdef-native_2.6.18+git.bb b/recipes/unifdef/unifdef-native_2.6.18+git.bb
new file mode 100644 (file)
index 0000000..f2992ca
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Kernel header preprocessor"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "file://unifdef.c"
+
+inherit native
+
+do_compile() {
+       ${CC} ${CFLAGS} ${LDFLAGS} -o unifdef ${WORKDIR}/unifdef.c
+}
+
+do_stage() {
+       install -m 0755 unifdef ${STAGING_BINDIR}
+}
+
+do_install() {
+       :
+}
+