clean up wlan.bb
[vuplus_openembedded] / recipes / tasks / task-vuplus-wlan.bb
index d5ed9ba..d9b575b 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: W-LAN Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r3"
+PR = "r6"
 
 inherit task
 
@@ -11,21 +11,12 @@ inherit task
 DESCRIPTION_${PN} = "Vuplus: W-LAN Support"
 DEPENDS_${PN} = "enigma2-plugins"
 RDEPENDS_${PN} = "\
-  enigma2-plugin-systemplugins-wirelesslan \
+  ${@base_contains("MACHINE_FEATURES", "vuwlan", "enigma2-plugin-systemplugins-wirelesslansetup", "enigma2-plugin-systemplugins-wirelesslan", d)} \
   wireless-tools \
   wpa-supplicant \
 "
 
 WLAN_CRYPTO_MODULES = "\
-  kernel-module-aes-generic \
-  kernel-module-arc4 \
-  kernel-module-ecb \
-  kernel-module-cryptomgr \
-  kernel-module-crypto-hash \
-  kernel-module-aead \
-  kernel-module-pcompress \
-  kernel-module-crypto-blkcipher \
-  kernel-module-crypto-algapi \
 "
 
 WLAN_PCI_MODULES = "\
@@ -37,11 +28,16 @@ WLAN_USB_MODULES = "\
   kernel-module-zd1211rw \
   rt73-firmware \
   zd1211-firmware \
+  r8192cu \
+  rt2870sta \
 "
 
 WLAN_USB_MODULES_LEGACY = "\
   zd1211b \
   wlan-rt73 \
+  r8712u \
+  rt3070 \
+  r8192cu \
 "
 
 RDEPENDS_${PN}_append_bm750 = "\