task-vuplus-enigma2 : add remotecontrolcode plugin to uno & ultimo
[vuplus_openembedded] / recipes / tasks / task-opendreambox-wlan.bb
index 7b78a67..7df01d6 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "OpenDreambox: W-LAN Task for the OpenDreambox Distribution"
 SECTION = "opendreambox/base"
 LICENSE = "MIT"
-PR = "r3"
+PR = "r6"
 
 inherit task
 
@@ -9,7 +9,7 @@ inherit task
 # task-opendreambox-wlan
 #
 DESCRIPTION_${PN} = "OpenDreambox: W-LAN Support"
-DEPENDS_${PN} = "enigma2-plugins"
+DEPENDS = "enigma2"
 RDEPENDS_${PN} = "\
   enigma2-plugin-systemplugins-wirelesslan \
   wireless-tools \
@@ -42,6 +42,8 @@ WLAN_USB_MODULES = "\
 WLAN_USB_MODULES_LEGACY = "\
   zd1211b \
   wlan-rt73 \
+  r8712u \
+  rt3070 \  
 "
 
 RDEPENDS_${PN}_append_dm500hd = "\
@@ -64,6 +66,14 @@ RDEPENDS_${PN}_append_dm8000 = "\
   ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', 'task-opendreambox-madwifi', '${WLAN_CRYPTO_MODULES} ${WLAN_PCI_MODULES}', d)} \
 "
 
+DEPENDS_append_dm8000 = "\
+  ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
+"
+
+RSUGGESTS_${PN}_append_dm8000 = "\
+  ${@base_contains('PREFERRED_VERSION_linux-dm8000', '2.6.18', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
+"
+
 RDEPENDS_${PN}_append_dm7025 = "\
   ${@base_contains('PREFERRED_VERSION_linux-dm7025', '2.6.12.6', '${WLAN_USB_MODULES_LEGACY}', '${WLAN_CRYPTO_MODULES} ${WLAN_USB_MODULES}', d)} \
 "