task-vuplus-enigma2.bb : append led brightness setup, ultimo
[vuplus_openembedded] / recipes / tasks / task-gstreamer-ti.bb
index cf05c7c..e7e13e5 100644 (file)
@@ -1,18 +1,28 @@
-# Task for dsp accelerated gstreamer plugins
+# Task for installing gstreamer plugins on TI platforms
 
-PR = "r1"
+PR = "r2"
 
-DEPENDS = "gst-plugins-base gst-plugins-bad gst-plugins-good gst-plugins-ugly gst-ffmpeg gstreamer-ti gst-openmax"
+DEPENDS = "gst-plugins-base gst-plugins-bad gst-plugins-good gst-plugins-ugly"
+
+GST_CODEC_ELEMENT = " \
+       gstreamer-ti \
+       gstreamer-ti-demo-script \
+"
+
+GST_CODEC_ELEMENT_am3517-evm = "\
+       gst-ffmpeg \
+       gst-omapfb \
+"
 
 RDEPENDS_${PN} = " \
-gst-plugins-base-meta \
-gst-plugins-good-meta \
-gst-plugins-bad-meta \
-gst-plugins-ugly-meta \
-gst-ffmpeg \
-gst-openmax \
-gstreamer-ti \
+       gst-plugins-base-meta \
+       gst-plugins-good-meta \
+       gst-plugins-bad-meta \
+       gst-plugins-ugly-meta \
+       ${GST_CODEC_ELEMENT} \
 "
 
 inherit task
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+