python_2.6.4.bb: build fix for host linux 3.0
[vuplus_openembedded] / recipes / python / python_2.6.4.bb
index 7e6203e..9f55114 100755 (executable)
@@ -45,6 +45,8 @@ TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
 TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
 
 do_configure_prepend() {
+       rm -R ${S}/Lib/plat-linux3 || /bin/true
+       ln -sf ${S}/Lib/plat-linux2 ${S}/Lib/plat-linux3
        autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || oenote "_ctypes failed to autoreconf"
 }