Merge branch 'vuplus-1.6' of 192.168.102.66:/var/ikseong/repo/openembedded into test_0921
[vuplus_openembedded] / recipes / linux / linux-dm8000_2.6.18.bb
index c77ac47..dafc133 100644 (file)
@@ -1,22 +1,20 @@
-require linux-opendreambox.inc
+require linux-opendreambox-2.6.18.inc
 
-SRCREV = "97b869e710d741d3eda4f7c915d6190b4054d290"
-PR="r3"
+PR="${PR_INC}.0"
 
-RREPLACES_kernel = "kernel-2.6.18-7.1-dm8000"
-RCONFLICTS_kernel = "kernel-2.6.18-7.1-dm8000"
-RREPLACES_kernel-image = "kernel-image-2.6.18-7.1-dm8000"
-RCONFLICTS_kernel-image = "kernel-image-2.6.18-7.1-dm8000"
+RDEPENDS += "dreambox-secondstage (>=83)"
 
-SRC_URI += " http://trappist.elis.ugent.be/~mronsse/cdfs/download/cdfs-2.6.18.tar.bz2 \
-       file://stblinux-2.6.18-cdfs.patch \
-       file://linux-2.6.18-fix-mips-crosscompile.patch;patch=1 \
-       file://linux-2.6.18-fix-proc-cputype.patch;patch=1 \
-       file://linux-2.6.18-disable-unneeded-uarts.patch;patch=1"
+SRC_URI += "\
+       file://linux-2.6.18-disable-unneeded-uarts.patch;patch=1 \
+       file://linux-2.6.18-use-full-flash.patch;patch=1 \
+"
 
-do_configure_prepend() {
-       if [ -d ${WORKDIR}/cdfs-${PV} ]; then
-               mv ${WORKDIR}/cdfs-${PV} ${S}/fs/cdfs
-               cd ${S} & patch -p1 < ${WORKDIR}/stblinux-2.6.18-cdfs.patch
+pkg_preinst_kernel-image_dm8000 () {
+       if [ -z "$D" ]; then
+               mountpoint -q /boot && mount -o rw,remount /boot;
+               if grep -q '^mtd3: 03c00000 ' /proc/mtd && ! grep -q '^legacy_flash_mapping=' /boot/secondstage.conf; then
+                       echo "enable legacy flash mapping in secondstage.conf";
+                       echo "legacy_flash_mapping=1;" >> /boot/secondstage.conf;
+               fi;
        fi;
 }