gnome-bluetooth git: move to 2.28.6
[vuplus_openembedded] / recipes / gnome / gnome-bluetooth_git.bb
index 23c4ca9..29bd3ea 100644 (file)
@@ -5,18 +5,18 @@ DEFAULT_PREFERENCE = "-1"
 
 inherit autotools gnome pkgconfig
 
-SRC_URI = "git://git.gnome.org/gnome-bluetooth;protocol=git \
+SRC_URI = "git://git.gnome.org/gnome-bluetooth;branch=gnome-2-28;protocol=git \
            file://gtk-doc.make \
 "
 
 S = "${WORKDIR}/git"
 
-SRCREV = "93fd8de2cc717b96ad719ab2fb5ed38b8a0fc707"
-PV = "2.27.5"
-PR = "r2"
+SRCREV = "2d23ec20fa8f8299e93beea849bc8670aa2c7c69"
+PV = "2.28.6"
+PR = "r0"
 PR_append = "+gitr${SRCREV}"
 
-DEPENDS = "obexd gconf-dbus gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
+DEPENDS = "geoclue obexd gconf gtk+ dbus-glib libunique libnotify hal bluez4 gnome-keyring"
 RRECOMMENDS_${PN} += "obexd"
 RCONFLICTS_${PN} = "bluez-gnome"
 
@@ -26,3 +26,6 @@ do_configure_prepend() {
        echo "EXTRA_DIST = version.xml" > gnome-doc-utils.make
 }
 
+# Todo: automagic plugin splitting
+
+FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug"