update PR of dvbapp.
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
index fbebca5..a51bd53 100644 (file)
@@ -6,7 +6,7 @@ DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi"
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
-       python-pickle gst-plugin-app \
+       python-pickle gst-plugin-app gst-plugin-fragmented \
        gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
        gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
        gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
@@ -63,9 +63,11 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wi
 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
+DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
+RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
 
 PN = "enigma2"
-PR = "r0"
+PR = "r21"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
@@ -131,8 +133,10 @@ SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
 
 SRC_URI_append_vuultimo = " \
-           file://orbitron-medium.ttf \
-           file://skin_user.xml"
+           file://analog.ttf \
+           file://skin_user.xml \
+           file://vfd_icons \
+"
 
 def change_po():
         import os
@@ -192,7 +196,7 @@ EXTRA_OECONF = " \
        ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
        ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
        ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
-       ${@base_contains("MACHINE_FEATURES", "remote-keyboard", "--with-remote-keyboard" , "", d)} \
+       ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
         BUILD_SYS=${BUILD_SYS} \
         HOST_SYS=${HOST_SYS} \
         STAGING_INCDIR=${STAGING_INCDIR} \
@@ -200,8 +204,10 @@ EXTRA_OECONF = " \
 "
 
 do_install_append_vuultimo() {
-        install -m 0755 ${WORKDIR}/orbitron-medium.ttf ${D}/usr/share/fonts/
+        install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
+        install -d ${D}/usr/share/enigma2/vfd_icons/
+        install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
 }
 
 python populate_packages_prepend () {