support manual-nameserver.
[vuplus_openembedded] / recipes / busybox / busybox_1.15.3.bb
index 9c95a1e..75cd5e7 100755 (executable)
@@ -1,5 +1,5 @@
 require busybox.inc
-PR = "${INC_PR}.6"
+PR = "${INC_PR}.7"
 
 SRC_URI = "\
   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
@@ -54,4 +54,8 @@ do_install_append() {
     if grep "CONFIG_DEVFSD=y" ${WORKDIR}/defconfig; then
         install -m 644 ${WORKDIR}/devfsd.conf ${D}${sysconfdir}
     fi
+    if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
+        install -d ${D}${sysconfdir}/udhcpc.d
+        install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
+    fi
 }