Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / base-files / base-files_3.0.14.bb
old mode 100644 (file)
new mode 100755 (executable)
index 892e84c..aabba45
@@ -1,7 +1,8 @@
 DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
-PR = "r89"
+PR = "r91"
+
 LICENSE = "GPL"
 
 SRC_URI = " \
@@ -45,8 +46,7 @@ dirs755 = "/bin /boot /dev ${sysconfdir} ${sysconfdir}/default \
           /mnt /media /media/card /media/cf /media/net /media/ram \
           /media/union /media/realroot /media/hdd \
           /media/mmc1"
-
-dirs755_micro = "/dev /proc ${sysconfdir}"
+dirs755_micro = "/dev /proc /sys ${sysconfdir}"
 dirs2775_micro = ""
 dirs1777_micro = "/tmp"
 
@@ -93,7 +93,7 @@ do_install () {
                echo ${hostname} > ${D}${sysconfdir}/hostname
        fi
 
-        if [ "${DISTRO}" != "micro" ]; then
+        if [ "${DISTRO}" != "micro" -a "${DISTRO}" != "micro-uclibc" ]; then
                 install -m 644 ${WORKDIR}/issue*  ${D}${sysconfdir}  
 
                 if [ -n "${DISTRO_NAME}" ]; then
@@ -131,7 +131,6 @@ do_install () {
        install -m 0644 ${WORKDIR}/nsswitch.conf ${D}${sysconfdir}/nsswitch.conf
 }
 
-
 do_install_append_mnci () {
        rmdir ${D}/tmp
        ln -s var/tmp ${D}/tmp
@@ -164,6 +163,13 @@ do_install_append_opendreambox() {
        ln -sf media ${D}/mnt
 }
 
+do_install_append_vuplus() {
+       rm -rf ${D}/mnt
+       rm -rf ${D}/hdd
+       ln -sf media/hdd ${D}/hdd
+       ln -sf media ${D}/mnt
+}
+
 PACKAGES = "${PN}-dbg ${PN}-doc ${PN}"
 FILES_${PN} = "/*"
 FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"