Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / vsftpd / vsftpd_2.0.5.bb
index 81aec46..3561fea 100644 (file)
@@ -1,12 +1,12 @@
 DESCRIPTION = "Secure ftp daemon"
 SECTION = "console/network"
 LICENSE = "GPL"
-DEPENDS = "openssl"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "ftp://vsftpd.beasts.org/users/cevans/vsftpd-${PV}.tar.gz \
            file://makefile.patch;patch=1 \
            file://nopam.patch;patch=1 \
+           file://syscall.patch;patch=1 \
            file://init \
            file://vsftpd.conf"
 
@@ -20,7 +20,7 @@ do_configure() {
 }
 
 do_compile() {
-        oe_runmake "LIBS=-lssl -lcrypto -lcrypt -L${STAGING_LIBDIR}"
+        oe_runmake "LIBS=-lcrypt -L${STAGING_LIBDIR}"
 }
 
 do_install() {
@@ -35,8 +35,12 @@ do_install() {
 }
 
 pkg_postinst() {
-        addgroup ftp
-        adduser --system --home /var/tmp/ftp --no-create-home --ingroup ftp --disabled-password -s /bin/false ftp
+        # can't do this offline
+        if [ "x$D" != "x" ]; then
+                exit 1
+        fi
+        addgroup ftp &&
+        adduser --system --home /var/tmp/ftp --no-create-home --ingroup ftp --disabled-password -s /bin/false ftp &&
         mkdir -p ${localstatedir}/share/empty
 }