samba, samba-essential: Move IFACE related autoconf variables to common-linux site...
[vuplus_openembedded] / packages / samba / samba-essential_3.0.20.bb
index 50d4e43..5486e0f 100644 (file)
@@ -1,21 +1,16 @@
-PR = "r3"
+require samba-essential.inc
+inherit update-rc.d
+
+PR = "r7"
 
-SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
-          file://configure.patch;patch=1 \
-          file://cifs.patch;patch=1 \
-          file://config-lfs.patch;patch=1 \
+SRC_URI = "file://config-lfs.patch;patch=1 \
           file://init-essential \
            file://quota.patch;patch=1;pnum=0 \
           file://smb-essential.conf \
-          file://smb-essential-inactive.conf \    
+          file://smb-essential-inactive.conf \
           file://Managing-Samba.txt"
-          
-S := ${WORKDIR}/samba-${PV}/source
 
-RCONFILCTS = samba
-
-include samba-essential.inc
-inherit update-rc.d
+RCONFLICTS = "samba"
 
 INITSCRIPT_NAME = "samba"
 # No dependencies, goes in at level 20 (NOTE: take care with the
@@ -42,29 +37,31 @@ do_install_append() {
        rm -f ${D}/sbin/mount.smbfs
        rmdir ${D}/sbin
        install -d "${D}${sysconfdir}/init.d"
+       install -d "${D}${sysconfdir}/samba/private"
+
        install -c -m 755 ${WORKDIR}/init-essential ${D}${sysconfdir}/init.d/samba
-       
-       install -d "${D}${sysconfdir}/samba"    
-       install -d "${D}/usr/share/samba/help"  
-       
+
+       install -d "${D}${sysconfdir}/samba"
+       install -d "${D}/usr/share/samba/help"
+
        install -m 0644 ${WORKDIR}/smb-essential-inactive.conf "${D}${sysconfdir}/samba/"
        install -m 0644 ${WORKDIR}/smb-essential.conf "${D}${sysconfdir}/samba/smb.conf"
 
        install -m 0644 ${WORKDIR}/Managing-Samba.txt  ${D}/usr/share/samba/help
-       
+
 }
 
 do_configure_append() {
        distro_up="`echo "${DISTRO}" | awk '{printf("%s\n",toupper($0))}'`"
-       
+
        cat ${WORKDIR}/smb-essential-inactive.conf | sed "s/MYWORKGROUP/${distro_up}/" > ${WORKDIR}/smb-essential-inactive.conf_
-       mv  ${WORKDIR}/smb-essential-inactive.conf_ ${WORKDIR}/smb-essential-inactive.conf 
+       mv  ${WORKDIR}/smb-essential-inactive.conf_ ${WORKDIR}/smb-essential-inactive.conf
 
        cat ${WORKDIR}/smb-essential.conf | sed "s/MYWORKGROUP/${distro_up}/" > ${WORKDIR}/smb-essential.conf_
-       mv  ${WORKDIR}/smb-essential.conf_ ${WORKDIR}/smb-essential.conf        
+       mv  ${WORKDIR}/smb-essential.conf_ ${WORKDIR}/smb-essential.conf
 }
 
-FILES_${PN} = "${bindir}/smbpasswd \          
+FILES_${PN} = "${bindir}/smbpasswd \
               ${sbindir}/nmbd \
               ${sbindir}/smbd \
               ${libdir}/charset \