compute TAG line in opie.bbclass instead of in (all) opie files
[vuplus_openembedded] / packages / opie-today-weatherplugin / opie-today-weatherplugin_1.1.9.bb
index e69de29..ac3a350 100644 (file)
@@ -0,0 +1,24 @@
+DESCRIPTION = "Weather plugin for Today"
+SECTION = "opie/today"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+DEPENDS = "libopiecore2 libopiepim2"
+RDEPENDS = "opie-today"
+
+APPNAME = "todayweatherplugin"
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/todayplugins/weather \
+           ${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
+
+S = "${WORKDIR}/weather"
+
+inherit opie
+
+# FILES plugins/today/libtodayweatherplugin.so* pics/todayweatherplugin
+do_install() {
+        install -d ${D}${palmtopdir}/pics/${APPNAME}/
+        install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+