Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / netkit-base / netkit-base_0.17.bb
index 6903381..f58ad4d 100644 (file)
@@ -1,13 +1,22 @@
 SECTION = "base"
 DESCRIPTION = "netkit-base includes the inetd daemon."
 LICENSE = "BSD"
+PR = "r1"
+
 SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-base-${PV}.tar.gz \
            file://configure.patch;patch=1 \
            file://mconfig.patch;patch=1 \
+           file://gcc4_buildfix.patch;patch=1;pnum=1 \
            file://init \
            file://inetd.conf"
 
+inherit update-rc.d
+
+INITSCRIPT_NAME = "inetd"
+INITSCRIPT_PARAMS = "start 20 2 3 4 5 . stop 20 0 1 6 ."
+
 EXTRA_OEMAKE = "-C inetd"
+
 do_compile () {
        oe_runmake 'CC=${CC}' 'LD=${LD}' all
 }
@@ -19,16 +28,3 @@ do_install () {
        install -m 0644 ${WORKDIR}/inetd.conf ${D}${sysconfdir}
 }
 
-pkg_postinst () {
-       if test -n "${D}"; then
-               D="-r $D"
-       fi
-       update-rc.d $D inetd start 20 2 3 4 5 . stop 20 0 1 6 .
-}
-
-pkg_prerm () {
-       if test -n "${D}"; then
-               D="-r $D"
-       fi
-       update-rc.d $D inetd remove
-}