Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / madwifi / madwifi-ng_r3314-20080131.bb
index d47a095..578c7cb 100644 (file)
@@ -1,17 +1,28 @@
 # Bitbake recipe for the madwifi-ng driver
 
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_ixp4xx = "1"
-
 # Disable stripping of kernel modules, since this action strips too
 # much out, and the resulting module won't load.
 INHIBIT_PACKAGE_STRIP = "1"
 
 require madwifi-ng_r.inc
 
-SRC_URI += " \
-       file://30-define-ioreadwrite32be-for-little-endian-too.patch;patch=1 \
-       "
-
 # PR set after the include, to override what's set in the included file.
-PR = "r6"
+PR = "r8"
+
+SRC_URI += "http://sources.dreamboxupdate.com/download/snapshots/openwrt_madwifi_patches_20080829.tar.bz2 \
+       http://sources.dreamboxupdate.com/download/snapshots/ath_hal-20080815.tgz \
+       file://40-fix-warnings.patch;patch=1;pnum=1"
+
+do_munge() {
+       rm -rf ${S}/hal || /bin/true
+       mv ${WORKDIR}/ath_hal-20080815 ${S}/hal
+       CUR=`pwd`
+       cd ${S}
+       for i in `ls ${WORKDIR}/openwrt_madwifi_patches | grep ".patch" | sort -n | xargs`; do
+               oenote "Applying openwrt madwifi patch '$i'";
+               patch -p1 < ${WORKDIR}/openwrt_madwifi_patches/$i;
+       done;
+       cd $CUR
+}
+
+addtask munge before do_compile after do_patch