merge of '49e39c42b944dda8eed607394e1849029b9f527f'
[vuplus_openembedded] / packages / linux / linux-dht-walnut_2.6.20.bb
index ca94ee8..8c1d2b8 100644 (file)
@@ -1,36 +1,25 @@
 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
 # Released under the MIT license (see packages/COPYING)
-SECTION = "kernel"
+require linux.inc
+
 DESCRIPTION = "Linux kernel for DHT-Walnut (ppc)  machine"
-LICENSE = "GPL"
-PR = "r3"
+
+PR = "r4"
 DEPENDS = "u-boot"
 
 COMPATIBLE_MACHINE = "dht-walnut"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
-           file://dht-walnut_defconfig"
-
+           file://defconfig"
 
 S = "${WORKDIR}/linux-${PV}"
 
-inherit kernel
-
-
 FILES_kernel-image = "/boot/zImage.elf"
 
 export OS = "Linux"
 ARCH = "ppc"
 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
 
-
-
-
-do_configure_prepend() {
-       install -m 0644 ${WORKDIR}/dht-walnut_defconfig ${S}/.config
-}
-
-
 do_stage_append () {
 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
 
@@ -42,24 +31,11 @@ do_stage_append () {
        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
 }
 
-
-
-
-
 do_install_append () {
         install -d  ${DEPLOY_DIR_IMAGE}
         install -m 0755 arch/ppc/boot/images/zImage.elf \ 
                 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
         install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
-        powerpc${TARGET_VENDOR}-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S \ 
-               ${DEPLOY_DIR_IMAGE}/vmlinux ${DEPLOY_DIR_IMAGE}/linux.bin
-        gzip -f -9 ${DEPLOY_DIR_IMAGE}/linux.bin
-        mkimage -A ppc -O linux -T kernel -C gzip -a 0 -e 0 -n "ppc405"+${PV} -d ${DEPLOY_DIR_IMAGE}/linux.bin.gz \ 
-                ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${MACHINE}-${DATETIME}.bin        
-        rm ${DEPLOY_DIR_IMAGE}/vmlinux
-        rm ${DEPLOY_DIR_IMAGE}/linux.bin.gz
-
-
 }