Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / libsidplay / libsidplay_1.36.59.bb
index dcb7be2..8f7859f 100644 (file)
@@ -3,16 +3,14 @@ SECTION = "libs"
 PRIORITY = "optional"
 LICENSE = "GPL"
 
-SRC_URI = "http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/libsidplay-${PV}.tgz"
+PR = "r1"
 
-inherit autotools 
+SRC_URI = "http://critical.ch/distfiles/libsidplay-${PV}.tgz \
+           http://ftp.debian.org/debian/pool/main/libs/libsidplay/libsidplay_1.36.59-5.diff.gz;patch=1 \
+"
+
+inherit autotools
 
 do_stage() {
-       oe_libinstall -so -C src libsidplay ${STAGING_LIBDIR}
-       install -d ${STAGING_INCDIR}/sidplay
-       for f in src/compconf.h src/emucfg.h src/fformat.h src/fixpoint.h src/libcfg.h src/myendian.h src/mytypes.h src/player.h src/sidtune.h src/version.h
-       do
-               install -m 0644 $f ${STAGING_INCDIR}/sidplay/
-       done
+       autotools_stage_all
 }
-