libidl - Firefox uses the libIDL-config-2 script instead of pkgconfig
[vuplus_openembedded] / packages / libidl / libidl_0.8.6.bb
index ee63b92..4265423 100644 (file)
@@ -2,15 +2,21 @@ LICENSE = "LGPL"
 DESCRIPTION = "Library for parsing CORBA IDL files"
 SECTION = "gnome/libs"
 DEPENDS = "glib-2.0"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-${PV}.tar.bz2"
 S = "${WORKDIR}/libIDL-${PV}"
 
 inherit autotools pkgconfig
 
+# Firefox uses the libIDL-config-2 script instead of pkgconfig (for some
+# strange reason - so we do some sed fu to fix the path there
+
 do_stage() {
        autotools_stage_all
+       
+       cp ${STAGING_BINDIR}/libIDL-config-2 ${STAGING_BINDIR}/libIDL-config-2.orig
+       cat ${STAGING_BINDIR}/libIDL-config-2.orig | sed -e 's:${includedir}:${STAGING_INCDIR}:' > ${STAGING_BINDIR}/libIDL-config-2
 }
 
 FILES_${PN} = "${libdir}/*.so.*"