Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.net/openembedde...
[vuplus_openembedded] / packages / images / fso-image.bb
index f1b9104..d67bd62 100644 (file)
@@ -2,54 +2,32 @@
 # freesmartphone.org Image Recipe
 #------------------------------------------------------
 
+PV = "1.0"
+PR = "r1"
+
+# no languages for now
 IMAGE_LINGUAS = ""
 
-# getting the base system up
 BASE_INSTALL = "\
-  ${MACHINE_TASK_PROVIDER} \
-  netbase \
-  sysfsutils \
-  module-init-tools-depmod \
-  rsync \
-  screen \
-  fbset \
-  fbset-modes \
+  task-base \
 "
 
-# getting an X window system up
+ILLUME_THEME = "illume-theme-fso"
+
 X_INSTALL = "\
-  e-wm \
-  illume \
-  illume-theme-freesmartphone \
-  ${XSERVER} \
-  xserver-kdrive-common \
-  xserver-nodm-init \
-  xauth \
-  xhost \
-  xset \
-  xrandr \
-  \
-  fontconfig-utils \
-  \
-  ttf-dejavu-common \
-  ttf-dejavu-sans \
-  ttf-dejavu-serif \
-  \
+  task-x11-illume \
+  task-fonts-truetype-core \
+"
+
+X_INSTALL_append_om-gta02 = "\
+  task-fonts-truetype-chinese \
+  task-fonts-truetype-japanese \
 "
 
-# useful command line tools
+# tools
 TOOLS_INSTALL = "\
-#  bash \
-  dosfstools \
-  htop \
-  iptables \
-  lsof \
-  mickeydbus \
-  mickeyterm \
-  mtd-utils \
-  nano \
-  powertop \
-  s3c24xx-gpio \
+  task-cli-tools \
+  task-cli-tools-python \
 "
 
 # audio
@@ -57,20 +35,25 @@ AUDIO_INSTALL = "\
   alsa-oss \
   alsa-state \
   alsa-utils-aplay \
+  alsa-utils-amixer \
   gst-meta-audio \
-  gst-plugin-mad \
   gst-plugin-modplug \
-  gst-plugin-sid \
+  ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad gst-plugin-sid', d)} \
   fso-sounds \
 "
 
 GTK_INSTALL = "\
   openmoko-calculator2 \
+  xterm \
   openmoko-terminal2 \
   gpe-scap \
   tangogps \
 "
 
+GAMES_INSTALL = "\
+  numptyphysics \
+"
+
 # FIXME these should rather be part of alsa-state,
 # once Om stabilizes them...
 AUDIO_INSTALL_append_om-gta01 = "\
@@ -87,26 +70,37 @@ PYTHON_INSTALL = "\
   python-gst \
 "
 
-# zhone
+# fso+zhone
 ZHONE_INSTALL = "\
-  gsm0710muxd \
-  frameworkd \
+  task-fso-compliance \
   zhone \
 "
 
+# additional apps
+APPS_INSTALL = "\
+  tichy \
+  gpe-gallery \
+  gpe-sketchbook \
+  gpe-filemanager \
+  vagalume \
+  starling \
+"
+
 IMAGE_INSTALL = "\
   ${BASE_INSTALL} \
   ${X_INSTALL} \
   ${GTK_INSTALL} \
+  ${GAMES_INSTALL} \
   ${AUDIO_INSTALL} \
   ${TOOLS_INSTALL} \
   ${PYTHON_INSTALL} \
   ${ZHONE_INSTALL} \
+  ${APPS_INSTALL} \
 "
 
 inherit image
 
-# perform some convenience tweaks to the rootfs
+# perform some convenience tweaks to the rootfs to improve the out-of-the-box experience :M:
 fso_rootfs_postprocess() {
     curdir=$PWD
     cd ${IMAGE_ROOTFS}
@@ -129,6 +123,12 @@ fso_rootfs_postprocess() {
     # minimal gtk theme foo
     mkdir -p ./etc/gtk-2.0/
     echo 'gtk-font-name = "Sans 5"' >> ./etc/gtk-2.0/gtkrc
+    # fix strange iconv/gconf bug
+    ln -s libc.so.6 ./lib/libc.so
+    # set sensible DNS entries
+    echo "nameserver 208.67.222.222" > ./etc/resolv.conf
+    echo "nameserver 208.67.220.220" >> ./etc/resolv.conf
+    # back on track
     cd $curdir
 }