Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / freesmartphone / frameworkd_git.bb
index 52bd54a..521fe5d 100644 (file)
@@ -1,18 +1,18 @@
-DESCRIPTION = "The freesmartphone.org Framework Daemon"
+DESCRIPTION = "The reference implementation of the freesmartphone.org framework APIs"
 HOMEPAGE = "http://www.freesmartphone.org"
 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
 SECTION = "console/network"
 DEPENDS = "python-cython-native python-pyrex-native"
 LICENSE = "GPL"
-PV = "0.8.2+gitr${SRCREV}"
-PR = "r3"
+PV = "0.8.4.2+gitr${SRCREV}"
+PR = "r0"
 
 inherit distutils update-rc.d
 
 INITSCRIPT_NAME = "frameworkd"
 INITSCRIPT_PARAMS = "defaults 29"
 
-SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
+SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=stabilization/milestone4 \
            file://frameworkd \
            file://frameworkd.conf"
 S = "${WORKDIR}/git"
@@ -24,8 +24,11 @@ do_install_append() {
 }
 
 RDEPENDS_${PN} += "\
+  python-ctypes \
   python-dbus \
   python-datetime \
+  python-difflib \
+  python-pprint \
   python-pygobject \
   python-pyrtc \
   python-pyserial \
@@ -33,12 +36,14 @@ RDEPENDS_${PN} += "\
   python-shell \
   python-subprocess \
   python-syslog \
+  python-textutils \
   \
   ${PN}-config \
 "
 
 RRECOMMENDS_${PN} += "\
   alsa-utils-amixer \
+  python-gst \
   ppp \
 "
 
@@ -47,10 +52,21 @@ RRECOMMENDS_${PN}_append_om-gta01 = "gsm0710muxd"
 RRECOMMENDS_${PN}_append_om-gta02 = "gsm0710muxd"
 
 PACKAGES =+ "${PN}-config"
-
 PACKAGE_ARCH_${PN}-config = "${MACHINE_ARCH}"
-FILES_${PN}-config = "${sysconfdir}/frameworkd.conf"
-CONFFILES_${PN}-config = "${sysconfdir}/frameworkd.conf"
+
+FILES_${PN}-config = "\
+  ${sysconfdir}/frameworkd.conf \
+  ${sysconfdir}/freesmartphone \
+"
+CONFFILES_${PN}-config = "\
+  ${sysconfdir}/frameworkd.conf \
+  ${sysconfdir}/freesmartphone/opreferences/conf/phone/silent.yaml \
+  ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
+  ${sysconfdir}/freesmartphone/opreferences/conf/profiles/default.yaml \
+  ${sysconfdir}/freesmartphone/opreferences/conf/rules/silent.yaml \
+  ${sysconfdir}/freesmartphone/opreferences/conf/rules/default.yaml \
+  ${sysconfdir}/freesmartphone/oevents/rules.yaml \
+"
 
 PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
 FILES_${PN} += "${sysconfdir}/dbus-1 ${sysconfdir}/freesmartphone ${sysconfdir}/init.d ${datadir}"