packages/enigma2/enigma2-plugins.bb: conf for release 2.8.0
[vuplus_openembedded] / packages / enigma2 / enigma2-plugins.bb
index 5a1b3da..762f44b 100755 (executable)
@@ -3,15 +3,15 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 
 PACKAGES_DYNAMIC = "enigma2-plugin-*"
 
-SRCDATE = "20091103"
+SRCDATE = "20100401"
 
-# if you want the 2.6.1 release, use
-#TAG = ";tag=enigma2-plugins_rel261"
-#PV = "2.6cvs${SRCDATE}"
+# if you want the 2.8.0 release, use
+TAG = ";tag=enigma2-plugins_rel28"
+PV = "2.8cvs${SRCDATE}"
 
 # if you want experimental, use:
-TAG = ""
-PV = "experimental-cvs${SRCDATE}"
+#TAG = ""
+#PV = "experimental-cvs${SRCDATE}"
 
 SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/enigma2-plugins;module=enigma2-plugins;method=pserver${TAG};date=${SRCDATE}"
 
@@ -23,7 +23,7 @@ inherit autotools
 
 S = "${WORKDIR}/enigma2-plugins"
 
-DEPENDS = "python-pyopenssl python-gdata"
+DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen"
 DEPENDS += "enigma2"
 
 python populate_packages_prepend () {
@@ -34,6 +34,10 @@ python populate_packages_prepend () {
        def getControlLines(mydir, d, package):
                import os
                try:
+                       #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
+                       #so the foldername is still ac3lipsync
+                       if package == 'audiosync':
+                               package = 'ac3lipsync'
                        src = open(mydir + package + "/CONTROL/control").read()
                except IOError:
                        return