packages/enigma2/enigma2-plugins.bb: conf for release 2.8.0
[vuplus_openembedded] / packages / enigma2 / enigma2-plugins.bb
old mode 100644 (file)
new mode 100755 (executable)
index 443003f..762f44b
@@ -1,40 +1,31 @@
 DESCRIPTION = "Additional plugins for Enigma2"
 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 
-SRCDATE = "20081111"
-
 PACKAGES_DYNAMIC = "enigma2-plugin-*"
 
-# if you want experimental, use:
-#REL_MAJOR="2"
-#REL_MINOR="5"
-#TAG = ""
+SRCDATE = "20100401"
 
-# if you want a 2.4-based release, use
-REL_MAJOR="2"
-REL_MINOR="4"
-TAG = ";tag=${PN}_rel${REL_MAJOR}${REL_MINOR}"
+# if you want the 2.8.0 release, use
+TAG = ";tag=enigma2-plugins_rel28"
+PV = "2.8cvs${SRCDATE}"
 
-REL_MINOR_dm8000="5"
-TAG_dm8000=""
-
-PV = "${REL_MAJOR}.${REL_MINOR}cvs${SRCDATE}"
+# if you want experimental, use:
+#TAG = ""
+#PV = "experimental-cvs${SRCDATE}"
 
 SRC_URI = "cvs://anonymous@cvs.schwerkraft.elitedvb.net/cvsroot/enigma2-plugins;module=enigma2-plugins;method=pserver${TAG};date=${SRCDATE}"
+
 FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
+FILES_${PN}-meta = "${datadir}/meta"
+PACKAGES += "${PN}-meta"
 
 inherit autotools
 
 S = "${WORKDIR}/enigma2-plugins"
 
-DEPENDS = "${@get_version_depends(bb, d)}"
+DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen"
 DEPENDS += "enigma2"
 
-def get_version_depends(bb, d):
-       if bb.data.getVar('REL_MINOR', d, 1) > '4':
-               return "python-pyopenssl"
-       return ""
-
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
 
@@ -43,6 +34,10 @@ python populate_packages_prepend () {
        def getControlLines(mydir, d, package):
                import os
                try:
+                       #ac3lipsync is renamed since 20091121 to audiosync.. but rename in cvs is not possible without lost of revision history..
+                       #so the foldername is still ac3lipsync
+                       if package == 'audiosync':
+                               package = 'ac3lipsync'
                        src = open(mydir + package + "/CONTROL/control").read()
                except IOError:
                        return
@@ -53,6 +48,13 @@ python populate_packages_prepend () {
                                bb.data.setVar('RDEPENDS_' + full_package, ' '.join(line[9:].split(', ')), d)
                        if line.startswith('Description: '):
                                bb.data.setVar('DESCRIPTION_' + full_package, line[13:], d)
+                       if line.startswith('Replaces: '):
+                               bb.data.setVar('RREPLACES_' + full_package, ' '.join(line[10:].split(', ')), d)
+                       if line.startswith('Conflicts: '):
+                               bb.data.setVar('RCONFLICTS_' + full_package, ' '.join(line[11:].split(', ')), d)
+                       if line.startswith('Maintainer: '):
+                               bb.data.setVar('MAINTAINER_' + full_package, line[12:], d)
+
 
        mydir = bb.data.getVar('D', d, 1) + "/../enigma2-plugins/"
        for package in bb.data.getVar('PACKAGES', d, 1).split():