ti-codec-combos: Combo Build Cleanup and additional html docs in package
[vuplus_openembedded] / packages / dsplink / ti-codec-combos_3.16.bb
index 60a976f..941856d 100644 (file)
@@ -4,27 +4,62 @@ LICENCE = "unknown"
 
 require ti-paths.inc
 
-# TODO update this...
-# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
-# Install the above link and put the omap3530_dvsdk_combos_3_16.tar.gz file in the same directory as this recipe
-SRC_URI = "file://omap3530_dvsdk_combos_3_16.tar.gz \
-   "
+SRC_URI = "http://software-dl.ti.com/sdo/sdo_apps_public_sw/omap3530_dvsdk_combos_tspa/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin \
+    "
 
 S = "${WORKDIR}/omap3530_dvsdk_combos_3_16"
+
 # Yes, the xdc stuff still breaks with a '.' in PWD
 PV = "316"
-PR = "r10"
+PR = "r13"
 
 TARGET = "all"
 
 export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/packages;${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
 
+# Needed for now since makefile in latest package assumes this is set
+export CODEC_INSTALL_DIR="${S}"
+
+# Helper function to run the binary installer and unpack the tar.gz in the same place as it was before - this could be optimised later
+do_accept_license() {
+        export HOME="${WORKDIR}"
+       chmod +x ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin
+        ${WORKDIR}/omap3530_dvsdk_combos_tspa-3_16-Linux-x86.bin --mode silent --prefix ${S}_install
+        cd "${S}_install"
+       tar -xzvf omap3530_dvsdk_combos_tspa_3_16.tar.gz
+       if [ -d ${S} ] ; then 
+            rm -rf ${S}
+        fi
+        mv omap3530_dvsdk_combos_tspa_3_16 ${S}
+}
+
+addtask accept_license after do_unpack before do_configure
+
 do_compile() {
-       sed -i -e s:/db/toolsrc/library/vendors2005/ti/c6x/6.0.16/Linux:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
-       -e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
-       -e s:/home/dvsdkval/workdir/OMAP3530/nfs/workdir/opt/toolchain/arm-2007q3:${CROSS_DIR}:g \
+
+        # For now, remove the reference to Rules.make and swap prod for eval, since this only has eval libs included
+        sed -i \
+        -e '/Rules.make/d' \
+        -e 's:$(FC_INSTALL_DIR)/packages;::g' \
+        -e 's:$(XDAIS_INSTALL_DIR)/packages;::g' \
+        -e 's:$(FC_INSTALL_DIR)/fctools/packages;::g' \
+        -e 's:$(BIOSUTILS_INSTALL_DIR)/packages;::g' \
+        -e 's:$(CMEM_INSTALL_DIR)/packages;::g' \
+        -e 's:$(LINK_INSTALL_DIR)/packages;::g' \
+        -e 's:$(LPM_INSTALL_DIR)/packages;::g' \
+        -e s:prod:eval:g \
+        ${S}/Makefile
+
+        # Fix-up config.bld to swap out hardcoded references to tools paths
+       sed -i -e s:/opt/dmsw/cg6x_6_0_16:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
        ${S}/config.bld
 
+       # Add make target to allow package to be prepared for building (normally this package is a binary release)
+        echo "makebuildable:
+       \$(XDC) .make -PR .
+" >> ${S}/Makefile
+
+        oe_runmake makebuildable
        oe_runmake clean
        oe_runmake
 }
@@ -41,7 +76,15 @@ do_install () {
                install ${i} ${D}/${datadir}/ti-codec-combos
        done
        
-       # should copy the generated data sheets as well for reference
+       # copy the generated data sheets as well for reference
+        #for i in $(find . -name "*.DataSheet.*") ; do
+
+        # infact, just copy all the html files (including the server datasheets) from the distro
+        #  - this includes top level html (with codec versions) + some qualiTI codec test reports
+        for i in $(find . -name "*.html") ; do
+                install ${i} ${D}/${datadir}/ti-codec-combos
+        done
+
 }
 
 do_stage () {