codec-engine: fix lpm build and clean up old files
[vuplus_openembedded] / packages / dsplink / codec-engine_2.21.bb
index 5040867..3ecef31 100644 (file)
@@ -8,7 +8,7 @@ RDEPENDS = "update-modules"
 inherit module
 
 # tconf from xdctools dislikes '.' in pwd :/
-PR = "r8"
+PR = "r9"
 PV = "221"
 
 # Get CE tarball from TI website, place in sources and calculate
@@ -19,8 +19,7 @@ SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_21.tar.gz \
            file://cmem-class-device-27-and-sched-include-fix.patch;patch=1 \
            file://dsplink-semaphore-27.patch;patch=1 \
            file://lpm-device-create-and-semaphore-include-fix.patch;patch=1 \
-           file://Makefile.dsplink \
-           file://Makefile-dsplink-kbuild \
+           file://lpm-make-symbol-warnings-fix.patch;patch=1 \
            file://Makefile-dsplink-gpp \
            file://Makefile-dsplink-dsp \
 "
@@ -76,7 +75,7 @@ do_compile_append() {
 
 do_stage_append() {
        install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine
-    cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/
+       cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/
        ln -sf ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/packages/ti/sdo/ce ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/cetools/packages/ti/sdo/
 }