Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / base-files / base-files_3.0.14.bb
index 98b522c..f518de4 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
-PR = "r75"
+PR = "r82"
 LICENSE = "GPL"
 
 SRC_URI = " \
@@ -19,8 +19,11 @@ SRC_URI = " \
            file://share/dot.profile \
            file://licenses/BSD \
            file://licenses/GPL-2 \
+           file://licenses/GPL-3 \
            file://licenses/LGPL-2 \
            file://licenses/LGPL-2.1 \
+           file://licenses/LGPL-3 \
+           file://licenses/GFDL-1.2 \
            file://licenses/Artistic "
 S = "${WORKDIR}"
 
@@ -109,7 +112,7 @@ do_install () {
        install -m 0644 ${WORKDIR}/host.conf ${D}${sysconfdir}/host.conf
        install -m 0644 ${WORKDIR}/motd ${D}${sysconfdir}/motd
 
-       for license in BSD GPL-2 LGPL-2 LGPL-2.1 Artistic; do
+       for license in BSD GPL-2 LGPL-2 LGPL-2.1 Artistic GPL-3 LGPL-3 GFDL-1.2; do
                install -m 0644 ${WORKDIR}/licenses/$license ${D}${datadir}/common-licenses/
        done
 
@@ -142,7 +145,15 @@ do_install_append_netbook-pro () {
        mkdir -p ${D}/initrd
 }
 
-PACKAGES = "${PN}-doc ${PN}"
+do_install_append_opendreambox() {
+       > ${D}/${sysconfdir}/resolv.conf
+       rm -rf ${D}/mnt
+       rm -rf ${D}/hdd
+       ln -sf media/hdd ${D}/hdd
+       ln -sf media ${D}/mnt
+}
+
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN}"
 FILES_${PN} = "/*"
 FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"