Merge oe-devel@oe-devel.bkbits.net:openembedded
[vuplus_openembedded] / nslu2-binary-only / unslung-standard-rootfs_2.3r25.bb
diff --git a/nslu2-binary-only/unslung-standard-rootfs_2.3r25.bb b/nslu2-binary-only/unslung-standard-rootfs_2.3r25.bb
deleted file mode 100644 (file)
index f3be5fb..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-SECTION = "base"
-
-PR = "r28"
-
-UNSLUNG_VERSION = "3.8-alpha"
-UNSLUNG_VARIANT ?= "standard"
-
-DEPENDS = "nslu2-linksys-libs"
-
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-rootfs-${PV}/${UNSLUNG_VARIANT}', '${FILE_DIRNAME}/unslung-rootfs-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r25.tar.bz2 \
-          file://README \
-          file://linuxrc \
-          file://unsling \
-          file://resling \
-          file://rc.unslung \
-          file://rc-diversion.patch;patch=1 \
-          file://rc.1-diversion.patch;patch=1 \
-          file://rc.crond-diversion.patch;patch=1 \
-          file://rc.halt-diversion.patch;patch=1 \
-          file://rc.local-diversion.patch;patch=1 \
-          file://rc.modules-diversion.patch;patch=1 \
-          file://rc.network-diversion.patch;patch=1 \
-          file://rc.quickset-diversion.patch;patch=1 \
-          file://rc.quota-diversion.patch;patch=1 \
-          file://rc.reboot-diversion.patch;patch=1 \
-          file://rc.reset_usrgrpshare-diversion.patch;patch=1 \
-          file://rc.rstimezone-diversion.patch;patch=1 \
-          file://rc.samba-diversion.patch;patch=1 \
-          file://rc.sysinit-diversion.patch;patch=1 \
-          file://rc.thttpd-diversion.patch;patch=1 \
-          file://rc.xinetd-diversion.patch;patch=1 \
-          file://root-passwd.patch;patch=1 \
-          file://create-ramdisks.patch;patch=1 \
-          file://remount-noatime.patch;patch=1 \
-          file://initialise-mtab.patch;patch=1 \
-          "
-
-S = "${WORKDIR}/nslu2-linksys-ramdisk-2.3r25"
-
-python () {
-       # Don't build unslung images unless we're targeting an nslu2
-       mach = bb.data.getVar("MACHINE", d, 1)
-       dist = bb.data.getVar("DISTRO", d, 1)
-       if mach != 'nslu2' or dist != 'unslung':
-               raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
-}
-
-do_compile () {
-       echo "V2.3R25-uNSLUng-${UNSLUNG_VARIANT}-${UNSLUNG_VERSION}" > ${S}/.unslung
-
-       sed -i -e s/@version#/@version#-uNSLUng-${UNSLUNG_VARIANT}-${UNSLUNG_VERSION}/ ${S}/home/httpd/html/home.htm
-       sed -i -e 's|>&nbsp;<|><a href="Unslung" class="mainmenu" target="_top">Unslung Doco</a><|' \
-               ${S}/home/httpd/html/manhead.htm
-
-       install -m 755 ${WORKDIR}/linuxrc ${S}/linuxrc
-       install -m 755 ${WORKDIR}/unsling ${S}/sbin/unsling
-       install -m 755 ${WORKDIR}/resling ${S}/sbin/resling
-       install -m 755 ${WORKDIR}/rc.unslung ${S}/etc/rc.d/rc.unslung
-
-       install -d ${S}/opt/doc
-       install -m 755 ${WORKDIR}/README ${S}/opt/doc/README
-       ln -s /opt/doc ${S}/home/httpd/html/Unslung
-
-       # Remove the libraries, because they are in nslu2-linksys-libs now
-       rm -rf ${S}/lib
-}
-
-do_install () {
-       ( cd ${S} ; tar -c -v -f - --exclude '*\~*' --exclude '.patches' . ) | ( cd ${D} ; tar xvf - )
-}
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/"
-RDEPENDS_${PN} = "nslu2-linksys-libs"