Merge
[vuplus_openembedded] / nslu2-binary-only / nslu2-linksys-ramdisk_2.3r25.bb
index e69de29..d774891 100644 (file)
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linksys NSLU2 Stock Firmware Ramdisk."
+PACKAGE_ARCH = "nslu2"
+SECTION = "base"
+PRIORITY = "required"
+PR = "r1"
+
+SRC_URI = "http://nslu.sf.net/downloads/nslu2-linksys-ramdisk-2.3r25.tar.bz2"
+
+do_install () {
+       ( cd ${S} ; tar cvf - . ) | ( cd ${D} ; tar xvf - )
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/"
+
+python () {
+       # Don't build unless we're targeting an nslu2
+       if oe.data.getVar("MACHINE", d, 1) != "nslu2":
+               raise oe.parse.SkipPackage("NSLU2 ramdisk only builds for the Linksys NSLU2")
+}