add usb hid
[vuplus_openembedded] / conf / machine / bm750.conf
index e930c41..6ff34a6 100644 (file)
@@ -4,50 +4,49 @@
 
 TARGET_ARCH = "mipsel"
 
-PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
-
-
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "vuplus-dvb-modules"
-
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel vuplus-dvb-modules \
-       kernel-module-cifs      kernel-module-exportfs  kernel-module-isofs \
-       kernel-module-reiserfs  \
-       kernel-module-sr-mod    kernel-module-usb-storage \
-       kernel-module-cdrom \
-       kernel-module-snd-pcm kernel-module-snd \
-       kernel-module-msdos kernel-module-vfat kernel-module-fat \
-       kernel-module-libata kernel-module-ntfs kernel-module-sata-svw \
-       kernel-module-nls-base kernel-module-nls-iso8859-1 kernel-module-nls-cp437 \
-       kernel-module-i2c-core kernel-module-firmware-class kernel-module-input kernel-module-evdev \
-       kernel-module-xfs"
+PREFERRED_VERSION_linux-bm750 = "2.6.18"
+PREFERRED_VERSION_linux-libc-headers = "2.6.18"
 
-TARGET_FPU = "soft"
-#TARGET_FPU = "hard"
+PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
 
-# used by sysvinit_2
-#SERIAL_CONSOLE = "115200 ttyS0"
 
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "kernel vuplus-dvb-modules \
+        kernel-module-isofs \
+        kernel-module-sr-mod    kernel-module-usb-storage \
+        kernel-module-cdrom \
+        kernel-module-msdos kernel-module-vfat kernel-module-fat \
+        kernel-module-libata kernel-module-ntfs kernel-module-sata-svw \
+        kernel-module-nls-base kernel-module-nls-iso8859-1 kernel-module-nls-cp437 \
+        kernel-module-nls-iso8859-15 kernel-module-nls-cp850 \
+        kernel-module-nls-utf8 \
+        kernel-module-i2c-core kernel-module-firmware-class kernel-module-input kernel-module-evdev \
+        kernel-module-snd-pcm kernel-module-snd \
+       kernel-module-tun \
+       kernel-module-fb \
+       v4l-dvb-module-dvb-core \
+        kernel-module-usbhid \
+        kernel-module-mousedev \
+        "
+
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS = "\
+        kernel-module-cifs \
+        kernel-module-exportfs \
+        kernel-module-ext2 \
+        kernel-module-reiserfs \
+        kernel-module-xfs \
+       "
+
+TARGET_FPU = "hard"
 
 MACHINE_FEATURES += "kernel26"
 
 TARGET_CC_ARCH = "-march=mips32"
 
-
-#PREFERRED_VERSION_linux-libc-headers = "2.6.18"
-
 DISTRO_FEATURES += " mplt"
 
-
-
-
 PREFERRED_PROVIDER_task-vuplus-dvbapi = "task-vuplus-dvbapi3"
 PREFERRED_PROVIDER_task-vuplus-ui = "task-vuplus-enigma2"
 
-
-
-
-
-#GLIBC_ADDONS = "nptl" which will be set at glibc_xxx.bb. Setting here causes a configure error.
 GLIBC_ADDONS ?= "ports,nptl,libidn"
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --without-fp --with-__thread"
 
@@ -56,6 +55,10 @@ PREFERRED_PROVIDER_xserver = "xserver-kdrive"
 EXTRA_IMAGEDEPENDS += "vuplus-makenfi-native"
 
 MACHINE_FEATURES += "alsa pci"
+MACHINE_FEATURES += "wifi"
+MACHINE_FEATURES += "vuwlan"
+MACHINE_FEATURES += "display-text-vfd"
+
 
 
 EXTRA_IMAGECMD_jffs2 = " --eraseblock=0x20000 -n -l "
@@ -77,7 +80,6 @@ IMAGE_CMD_jffs2 = " \
        cp ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.vmlinux.gz ${DEPLOY_DIR_IMAGE}/vuplus/duo/kernel_cfe_auto.bin; \
        cp ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.boot.jffs2 ${DEPLOY_DIR_IMAGE}/vuplus/duo/boot_cfe_auto.jffs2; \
        cd ${DEPLOY_DIR_IMAGE}; \
-       rm -f usb_upgrade.zip; \
-       zip usb_upgrade.zip vuplus/duo/*; \
+       zip ${IMAGE_NAME}_usb.zip vuplus/duo/*; \
        rm -rf vuplus; \       
 "