dvbmediasink : support DDP patch.
[vuplus_openembedded] / conf / local.conf.sample
index 9d23b65..643ae0b 100644 (file)
@@ -23,7 +23,7 @@
 DL_DIR = "${HOME}/sources"
 
 # Delete the line below. Then specify which .bb files to consider for
-# your build. Typically this will be something like BBFILES = "/path/to/openembedded/packages/*/*.bb"
+# your build. Typically this will be something like BBFILES = "/path/to/openembedded/recipes/*/*.bb"
 BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
 
 # Use the BBMASK below to instruct BitBake to _NOT_ consider some .bb files
@@ -33,17 +33,25 @@ BBMASK = ""
 # Uncomment this if you want to use a prebuilt toolchain. You will need to
 # provide packages for toolchain and additional libraries yourself. You also
 # have to set PATH in your environment to make sure BitBake finds additional binaries.
-# Note: You will definitely need to say:
-#     ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"
-# to build any of two Linux 2.4 Embedix kernels,
+# ASSUME_PROVIDED += "virtual/${TARGET_PREFIX}gcc virtual/libc"
+
+# Uncomment this if you're building for an arch that uses emulated locale 
+# generation under qemu (mainly arm glibc) and have an external gcc 3.x compiler
+# that OE recognises. This will mean the gcc-native build is skipped, speeding 
+# builds up.
+# ASSUME_PROVIDED += "gcc3-native"
+
+# Uncomment this if you are building Linux 2.4 Embedix kernels.
 # i.e. openzaurus-sa-2.4.18 and openzaurus-pxa-2.4.18 - and don't forget
 # to rename the binaries as instructed in the Wiki.
-# ASSUME_PROVIDED += "virtual/${TARGET_PREFIX}gcc virtual/libc"
+# Most users do not need this anymore thankfully!
+# ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"
 
 # Select between multiple alternative providers, if more than one is eligible.
 PREFERRED_PROVIDERS = "virtual/qte:qte virtual/libqpe:libqpe-opie"
-PREFERRED_PROVIDERS += " virtual/libsdl:libsdl-qpe"
+PREFERRED_PROVIDERS += " virtual/libsdl:libsdl-x11"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-intermediate:gcc-cross-intermediate"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 
@@ -55,8 +63,9 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 # TMPDIR = /usr/local/projects/oetmp
 
 # Uncomment this to specify a machine to build for. See the conf directory
-# for machines currently known to OpenEmbedded.
-# MACHINE = "collie"
+# for machines currently known to OpenEmbedded. This will automatically take care
+# of TARGET_ARCH
+# MACHINE = "c7x0"
 
 # Use this to specify the target architecture. Note that this is only
 # needed when building for a machine not known to OpenEmbedded. Better use
@@ -66,28 +75,35 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 # Use this to specify the target operating system.  The default is "linux",
 # for a normal linux system with glibc. Set this to "linux-uclibc" if you want
 # to build a uclibc based system.
+# Normally the DISTRO of your choosing will take care of this 
 # TARGET_OS = "linux"
 # TARGET_OS = "linux-uclibc"
 
 # Uncomment this to select a distribution policy. See the conf directory
 # for distributions currently known to OpenEmbedded.
-# Although they no longer contain version number in the (file-)name
-# familiar-unstable and openzaurus-unstable are so called "versioned"
-# distros, i.e. they explicitely select specific versions of various
-# packages.
+# Although it no longer contain version number in the (file-)name
+# openzaurus-unstable is a so called "versioned"  distro, i.e. they 
+# explicitely select specific versions of various packages.
 # Stay away from unversioned distros unless you really know what you are doing
-# DISTRO = "familiar-unstable"
+# DISTRO = "angstrom-2008.1"
 
-# So far, angstrom.conf and familiar.conf set ENABLE_BINARY_LOCALE_GENERATION
+# So far, angstrom.conf sets ENABLE_BINARY_LOCALE_GENERATION
 # to generate binary locale packages at build time using qemu-native and
 # thereby guarantee i18n support on all devices. If your build breaks on 
 # qemu-native consider disabling ENABLE_BINARY_LOCALE_GENERATION (note that
 # this breaks i18n on devices with less than 128MB RAM) or installing
 # a working third-party qemu (e.g. provided by your distribution) and
-# adding qemu-native to ASSUME_PROVIDED
+# adding qemu-native to ASSUME_PROVIDED. Caveat emptor, since third-party
+# qemus lack patches needed to work with various OE targets.
 # ENABLE_BINARY_LOCALE_GENERATION = "0"
 # ASSUME_PROVIDED += "qemu-native"
 
+# If ENABLE_BINARY_LOCALE_GENERATION is set to "1", you can limit locales
+# generated to the list provided by GLIBC_GENERATE_LOCALES. This is huge
+# time-savior for developmental builds. Format: list of locale.encoding pairs
+# with spaces as separators.
+# GLIBC_GENERATE_LOCALES = "en_US.UTF-8 en_GB.UTF-8 de_DE.UTF-8"
+
 # Uncomment this to select a particular major kernel version if the MACHINE setting
 # supports more than one major kernel version. Currently this is suported by the
 # following MACHINE types: poodle, tosa and simpad.
@@ -98,9 +114,16 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 # INHERIT = "package_ipk"
 # INHERIT = "package_tar"
 
-# Add the required image file system types below. Valid are jffs2, tar, cramfs and ext2
+# Add the required image file system types below. Valid are 
+# jffs2, tar(.gz|bz2), cpio(.gz), cramfs, ext2(.gz), ext3(.gz)
+# squashfs, squashfs-lzma
 IMAGE_FSTYPES = "jffs2 tar"
 
+# Uncomment this if you want to keep the temporary rootfs
+# diretory, this can be useful during development.
+# (Note that this rootfs is NOT usuable as NFS export.)
+# IMAGE_KEEPROOTFS = "1"
+
 # Uncomment this to disable the parse cache (not recommended).
 # CACHE = ""
 
@@ -108,7 +131,8 @@ IMAGE_FSTYPES = "jffs2 tar"
 # BBDEBUG = "yes"
 
 # Uncomment these two if you want BitBake to build images useful for debugging. 
-# Note that INHIBIT_PACKAGE_STRIP needs a package format to be defined
+# Note that INHIBIT_PACKAGE_STRIP needs a package format to be defined.
+# Also note that OE now produces -dbg packages which contain debugging symbols.
 # DEBUG_BUILD = "1"
 # INHIBIT_PACKAGE_STRIP = "1"
 
@@ -128,12 +152,22 @@ IMAGE_FSTYPES = "jffs2 tar"
 # in the process of marking these so let us know if you find any.
 # PARALLEL_MAKE = "-j 4"
 
+# Uncomment to run multiple bitbake threads in parallel.
+# Bitbake can do multiple jobs in parallel: Its a good idea make use of 
+# all available resources: e.g. to download sources while some other
+# piece of software is compiled.
+# BB_NUMBER_THREADS = "2"
+
 # Uncomment this if you want BitBake to emit the log if a build fails.
 BBINCLUDELOGS = "yes"
 
 # Specifies a location to search for pre-generated tarballs when fetching
 # a cvs:// URI. Outcomment this, if you always want to pull directly from CVS.
-CVS_TARBALL_STASH = "http://www.oesources.org/source/current/"
+#CVS_TARBALL_STASH = ""
+
+# Uncomment this if you want to install shared libraries directly under their SONAME,
+# rather than installing as the full version and symlinking to the SONAME.
+# PACKAGE_SNAP_LIB_SYMLINKS = "1"
 
 # EDIT THIS FILE and then remove the line below before using!
-REMOVE_THIS_LINE:="${@oe.fatal('Read the comments in your conf/local.conf')}"
+REMOVE_THIS_LINE:="${@bb.fatal('Read the comments in your conf/local.conf')}"