dvbmediasink : support DDP patch.
[vuplus_openembedded] / conf / local.conf.sample
index 213ed12..643ae0b 100644 (file)
@@ -23,7 +23,7 @@
 DL_DIR = "${HOME}/sources"
 
 # Delete the line below. Then specify which .bb files to consider for
-# your build. Typically this will be something like BBFILES = "/path/to/openembedded/packages/*/*.bb"
+# your build. Typically this will be something like BBFILES = "/path/to/openembedded/recipes/*/*.bb"
 BBFILES := "${@bb.fatal('Edit your conf/local.conf: BBFILES')}"
 
 # Use the BBMASK below to instruct BitBake to _NOT_ consider some .bb files
@@ -51,6 +51,7 @@ BBMASK = ""
 PREFERRED_PROVIDERS = "virtual/qte:qte virtual/libqpe:libqpe-opie"
 PREFERRED_PROVIDERS += " virtual/libsdl:libsdl-x11"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-intermediate:gcc-cross-intermediate"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc:gcc-cross"
 PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 
@@ -101,7 +102,7 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 # generated to the list provided by GLIBC_GENERATE_LOCALES. This is huge
 # time-savior for developmental builds. Format: list of locale.encoding pairs
 # with spaces as separators.
-# GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 de_DE.UTF-8"
+# GLIBC_GENERATE_LOCALES = "en_US.UTF-8 en_GB.UTF-8 de_DE.UTF-8"
 
 # Uncomment this to select a particular major kernel version if the MACHINE setting
 # supports more than one major kernel version. Currently this is suported by the
@@ -118,6 +119,11 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
 # squashfs, squashfs-lzma
 IMAGE_FSTYPES = "jffs2 tar"
 
+# Uncomment this if you want to keep the temporary rootfs
+# diretory, this can be useful during development.
+# (Note that this rootfs is NOT usuable as NFS export.)
+# IMAGE_KEEPROOTFS = "1"
+
 # Uncomment this to disable the parse cache (not recommended).
 # CACHE = ""
 
@@ -146,6 +152,12 @@ IMAGE_FSTYPES = "jffs2 tar"
 # in the process of marking these so let us know if you find any.
 # PARALLEL_MAKE = "-j 4"
 
+# Uncomment to run multiple bitbake threads in parallel.
+# Bitbake can do multiple jobs in parallel: Its a good idea make use of 
+# all available resources: e.g. to download sources while some other
+# piece of software is compiled.
+# BB_NUMBER_THREADS = "2"
+
 # Uncomment this if you want BitBake to emit the log if a build fails.
 BBINCLUDELOGS = "yes"
 
@@ -153,5 +165,9 @@ BBINCLUDELOGS = "yes"
 # a cvs:// URI. Outcomment this, if you always want to pull directly from CVS.
 #CVS_TARBALL_STASH = ""
 
+# Uncomment this if you want to install shared libraries directly under their SONAME,
+# rather than installing as the full version and symlinking to the SONAME.
+# PACKAGE_SNAP_LIB_SYMLINKS = "1"
+
 # EDIT THIS FILE and then remove the line below before using!
 REMOVE_THIS_LINE:="${@bb.fatal('Read the comments in your conf/local.conf')}"