Update drivers
[vuplus_openembedded] / classes / autotools.bbclass
index fccf2b6..1ea4b6f 100644 (file)
@@ -1,8 +1,7 @@
-inherit base
+# use autotools_stage_all for native packages
+AUTOTOOLS_NATIVE_STAGE_INSTALL = "1"
 
 def autotools_dep_prepend(d):
-       import bb;
-
        if bb.data.getVar('INHIBIT_AUTOTOOLS_DEPS', d, 1):
                return ''
 
@@ -17,18 +16,22 @@ def autotools_dep_prepend(d):
                deps += 'libtool-native '
                if not bb.data.inherits_class('native', d) \
                         and not bb.data.inherits_class('cross', d) \
+                        and not bb.data.inherits_class('sdk', d) \
                         and not bb.data.getVar('INHIBIT_DEFAULT_DEPS', d, 1):
                     deps += 'libtool-cross '
 
        return deps + 'gnu-config-native '
 
 EXTRA_OEMAKE = ""
+
 DEPENDS_prepend = "${@autotools_dep_prepend(d)}"
+DEPENDS_virtclass-native_prepend = "${@autotools_dep_prepend(d)}"
+DEPENDS_virtclass-nativesdk_prepend = "${@autotools_dep_prepend(d)}"
+
 acpaths = "default"
 EXTRA_AUTORECONF = "--exclude=autopoint"
 
 def autotools_set_crosscompiling(d):
-       import bb
        if not bb.data.inherits_class('native', d):
                return " cross_compiling=yes"
        return ""
@@ -97,9 +100,9 @@ autotools_do_configure() {
                        AUTOV=`automake --version |head -n 1 |sed "s/.* //;s/\.[0-9]\+$//"`
                        automake --version
                        echo "AUTOV is $AUTOV"
-                       install -d ${STAGING_DIR}/${HOST_SYS}/share/aclocal
-                       install -d ${STAGING_DIR}/${HOST_SYS}/share/aclocal-$AUTOV
-                       acpaths="$acpaths -I ${STAGING_DIR}/${HOST_SYS}/share/aclocal-$AUTOV -I ${STAGING_DIR}/${HOST_SYS}/share/aclocal"
+                       install -d ${STAGING_DATADIR}/aclocal
+                       install -d ${STAGING_DATADIR}/aclocal-$AUTOV
+                       acpaths="$acpaths -I${STAGING_DATADIR}/aclocal-$AUTOV -I ${STAGING_DATADIR}/aclocal"
                        # autoreconf is too shy to overwrite aclocal.m4 if it doesn't look
                        # like it was auto-generated.  Work around this by blowing it away
                        # by hand, unless the package specifically asked not to run aclocal.
@@ -111,7 +114,7 @@ autotools_do_configure() {
                        else
                          CONFIGURE_AC=configure.ac
                        fi
-                       if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+                       if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
                          if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
                            : do nothing -- we still have an old unmodified configure.ac
                          else
@@ -119,19 +122,19 @@ autotools_do_configure() {
                            echo "no" | glib-gettextize --force --copy
                          fi
                        fi
-                       if grep "^[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+                       mkdir -p m4
+                       if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
                          oenote Executing intltoolize --copy --force --automake
                          intltoolize --copy --force --automake
                        fi
                        oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
-                       mkdir -p m4
                        autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
                        cd $olddir
                fi
        ;;
        esac
        if [ -e ${S}/configure ]; then
-               oe_runconf
+               oe_runconf $@
        else
                oenote "nothing to configure"
        fi
@@ -139,13 +142,22 @@ autotools_do_configure() {
 
 autotools_do_install() {
        oe_runmake 'DESTDIR=${D}' install
+}
 
-        for i in `find ${D} -name "*.la"` ; do \
-            sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i
-            sed -i -e s:${D}::g $i
-            sed -i -e 's:-I${WORKDIR}\S*: :g' $i
-            sed -i -e 's:-L${WORKDIR}\S*: :g' $i
-       done
+PACKAGE_PREPROCESS_FUNCS += "autotools_prepackage_lamangler"
+
+autotools_prepackage_lamangler () {
+        for i in `find ${PKGD} -name "*.la"` ; do \
+                sed -i -e '/^dependency_libs=/s,${WORKDIR}[[:alnum:]/\._+-]*/\([[:alnum:]\._+-]*\),${libdir}/\1,g' $i
+                sed -i -e s:${CROSS_DIR}/${HOST_SYS}::g $i
+                sed -i -e s:${CROSS_DIR}::g $i
+                sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i
+                sed -i -e s:${STAGING_DIR_HOST}::g $i
+                sed -i -e s:${STAGING_DIR}::g $i
+                sed -i -e s:${S}::g $i
+                sed -i -e s:${T}::g $i
+                sed -i -e s:${D}::g $i
+        done
 }
 
 STAGE_TEMP="${WORKDIR}/temp-staging"
@@ -161,6 +173,14 @@ autotools_stage_includes() {
        fi
 }
 
+autotools_stage_dir() {
+       sysroot_stage_dir $1 ${STAGE_TEMP_PREFIX}$2
+}
+
+autotools_stage_libdir() {
+       sysroot_stage_libdir $1 ${STAGE_TEMP_PREFIX}$2
+}
+
 autotools_stage_all() {
        if [ "${INHIBIT_AUTO_STAGE}" = "1" ]
        then
@@ -169,25 +189,11 @@ autotools_stage_all() {
        rm -rf ${STAGE_TEMP}
        mkdir -p ${STAGE_TEMP}
        oe_runmake DESTDIR="${STAGE_TEMP}" install
-       if [ -d ${STAGE_TEMP}/${includedir} ]; then
-               cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
-       fi
-       if [ -d ${STAGE_TEMP}/${libdir} ]
-       then
-               for i in ${STAGE_TEMP}/${libdir}/*.la
-               do
-                       if [ ! -f "$i" ]; then
-                               cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
-                               break
-                       fi
-                       oe_libinstall -so $(basename $i .la) ${STAGING_LIBDIR}
-               done
-       fi
-       if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
-               install -d ${STAGING_DATADIR}/aclocal
-               cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
-       fi
+       rm -rf ${STAGE_TEMP}/${mandir} || true
+       rm -rf ${STAGE_TEMP}/${infodir} || true
+       sysroot_stage_dirs ${STAGE_TEMP} ${STAGE_TEMP_PREFIX}
        rm -rf ${STAGE_TEMP}
 }
 
 EXPORT_FUNCTIONS do_configure do_install
+