Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / zlapspeed / zlapspeed_1.0.0.bb
1 DESCRIPTION = "Zaurus Race Lap Speed Measuring Application for Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5
6 SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zlaps/zlaps_${PV}_arm.src.tar.gz \
7            file://qtopia17.patch;patch=1"
8 S = "${WORKDIR}/zlaps-src"
9
10 inherit palmtop
11
12 EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
13
14 do_install() {
15         install -d ${D}${palmtopdir}/{bin,pics,apps/Applications}
16         install -m 0755 zlaps ${D}${palmtopdir}/bin/
17         install -m 0755 images/zlaps.png ${D}${palmtopdir}/pics/
18         install -m 0644 zlaps.desktop ${D}${palmtopdir}/apps/Applications/
19 }