increase dvbapp PR.
[vuplus_openembedded] / recipes / yum / createrepo-native_0.9.bb
1 DEPENDS = "python-native"
2
3 SRC_URI = "http://createrepo.baseurl.org/download/createrepo-${PV}.tar.gz \
4            file://fix.patch;patch=1 \
5            file://pathfix.patch;patch=1 "
6 PR = "r1"
7
8 inherit autotools native
9
10 S = "${WORKDIR}/createrepo-${PV}"
11
12 do_compile_append () {
13         sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/createrepo
14         sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/modifyrepo
15         sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/genpkgmetadata.py
16         sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/modifyrepo.py
17 }